store | blogs | forums | twitter | facebook | wiki | downloads | support portal
Atomic Secure Linux
It is currently Tue Oct 22, 2019 2:53 am

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Latest atomic repo release of mysql fails to install
Unread postPosted: Tue Feb 10, 2015 7:47 pm 
Offline
Forum User
Forum User

Joined: Mon Jun 14, 2010 8:39 pm
Posts: 29
I see that a new update for MySQL was released yesterday. I am unable to install it due to errors. Has anyone else seen this and have a solution to get it to install. Here is the output of yum update.

Code:
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package mysql.i386 0:5.5.42-28.el5.art set to be updated
--> Processing Dependency: real-mysql-libs = 5.5.42-28.el5.art for package: mysql
---> Package mysql-server.i386 0:5.5.42-28.el5.art set to be updated
--> Running transaction check
---> Package mysql-libs.i386 0:5.5.42-28.el5.art set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

========================================================================================================================================================================
 Package                                   Arch                              Version                                          Repository                           Size
========================================================================================================================================================================
Updating:
 mysql                                     i386                              5.5.42-28.el5.art                                atomic                              7.6 M
 mysql-server                              i386                              5.5.42-28.el5.art                                atomic                               13 M
Installing for dependencies:
 mysql-libs                                i386                              5.5.42-28.el5.art                                atomic                              1.1 M

Transaction Summary
========================================================================================================================================================================
Install       1 Package(s)
Upgrade       2 Package(s)

Total download size: 22 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): mysql-libs-5.5.42-28.el5.art.i386.rpm                                                                                                     | 1.1 MB     00:00     
(2/3): mysql-5.5.42-28.el5.art.i386.rpm                                                                                                          | 7.6 MB     00:01     
(3/3): mysql-server-5.5.42-28.el5.art.i386.rpm                                                                                                   |  13 MB     00:01     
------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                   4.8 MB/s |  22 MB     00:04     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /usr/share/man/man1/my_print_defaults.1.gz from install of mysql-5.5.42-28.el5.art.i386 conflicts with file from package mysql-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysql.1.gz from install of mysql-5.5.42-28.el5.art.i386 conflicts with file from package mysql-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysql_config.1.gz from install of mysql-5.5.42-28.el5.art.i386 conflicts with file from package mysql-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysql_find_rows.1.gz from install of mysql-5.5.42-28.el5.art.i386 conflicts with file from package mysql-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysql_waitpid.1.gz from install of mysql-5.5.42-28.el5.art.i386 conflicts with file from package mysql-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysqlaccess.1.gz from install of mysql-5.5.42-28.el5.art.i386 conflicts with file from package mysql-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysqladmin.1.gz from install of mysql-5.5.42-28.el5.art.i386 conflicts with file from package mysql-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysqldump.1.gz from install of mysql-5.5.42-28.el5.art.i386 conflicts with file from package mysql-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysqlshow.1.gz from install of mysql-5.5.42-28.el5.art.i386 conflicts with file from package mysql-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysqlslap.1.gz from install of mysql-5.5.42-28.el5.art.i386 conflicts with file from package mysql-5.5.41-27.el5.art.x86_64
  file /usr/bin/mysql_install_db from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/bin/mysqld_safe from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/innochecksum.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/msql2mysql.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/myisam_ftdump.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/myisamchk.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/myisamlog.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/myisampack.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysql.server.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysql_convert_table_format.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysql_fix_extensions.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysql_install_db.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysql_plugin.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysql_secure_installation.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysql_setpermission.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysql_tzinfo_to_sql.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysql_upgrade.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysql_zap.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysqlbinlog.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysqlbug.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysqlcheck.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysqld_multi.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysqld_safe.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysqldumpslow.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysqlhotcopy.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysqlimport.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/mysqltest.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/perror.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/replace.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/resolve_stack_dump.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man1/resolveip.1.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/man/man8/mysqld.8.gz from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64
  file /usr/share/mysql/fill_help_tables.sql from install of mysql-server-5.5.42-28.el5.art.i386 conflicts with file from package mysql-server-5.5.41-27.el5.art.x86_64

Error Summary
-------------


Top
 Profile  
Reply with quote  
 Post subject: Re: Latest atomic repo release of mysql fails to install
Unread postPosted: Wed Feb 11, 2015 4:52 am 
Offline
New Forum User
New Forum User

Joined: Wed Feb 11, 2015 4:40 am
Posts: 2
Location: Belgium
Hi lfenison,

As you can see at https://www.atomicorp.com/channels/atom ... 6_64/RPMS/ AtomiCorp only released the i386 packages for the latest MySQL version:
Code:
mysql-5.5.41-27.el5.art.i386.rpm     Dec 03 2014 10:58:09   7779kb    <-- previous version available for i386
mysql-5.5.41-27.el5.art.x86_64.rpm   Dec 03 2014 10:51:23   7642kb    <-- previous version available for x86_64
mysql-5.5.42-28.el5.art.i386.rpm     Feb 09 2015 19:13:08   7775kb    <-- new version only available for i386

As you have installed both i386 and x86_64 version, you can not update the packages at this moment.

AtomiCorp, is there a reason no x886_64 version is currently available? Will it be added?


Top
 Profile  
Reply with quote  
 Post subject: Re: Latest atomic repo release of mysql fails to install
Unread postPosted: Wed Feb 11, 2015 10:03 am 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin

Joined: Wed Dec 31, 1969 8:00 pm
Posts: 8329
Location: earth
Yeah just that el5 is getting long in the tooth, and the packages for it dont always build without some help.


Top
 Profile  
Reply with quote  
 Post subject: Re: Latest atomic repo release of mysql fails to install
Unread postPosted: Thu Feb 12, 2015 4:58 am 
Offline
New Forum User
New Forum User

Joined: Wed Feb 11, 2015 4:40 am
Posts: 2
Location: Belgium
scott wrote:
Yeah just that el5 is getting long in the tooth, and the packages for it dont always build without some help.

Hi scott, thanks! Updates are running fine now.


Top
 Profile  
Reply with quote  
 Post subject: Re: Latest atomic repo release of mysql fails to install
Unread postPosted: Thu Feb 12, 2015 10:35 am 
Offline
Forum User
Forum User

Joined: Mon Jun 14, 2010 8:39 pm
Posts: 29
scott wrote:
Yeah just that el5 is getting long in the tooth, and the packages for it dont always build without some help.


Working great for me now on el5


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group