Latest memcached gives a lot of problem

General Discussion of atomic repo and development projects.

Ask for help here with anything else not covered by other forums.
templenode
New Forum User
New Forum User
Posts: 1
Joined: Fri Apr 24, 2015 4:26 am
Location: Europe

Latest memcached gives a lot of problem

Unread post by templenode »

The latest memcached 1.4.23-5.el6.art fails to work correctly.
After upgrade I notice some websites were down with error with failed to connect to memcached. Daemon was running but after a couple of test I saw that even the command memcached-tool 127.0.0.1:11211 stats was not able to be executed.

stace stops here

Code: Select all

read(3, "", 4096)                       = 0
close(3)                                = 0
socket(PF_INET, SOCK_STREAM, IPPROTO_TCP) = 3
ioctl(3, SNDCTL_TMR_TIMEBASE or TCGETS, 0x7fff6ffa3460) = -1 EINVAL (Invalid argument)
lseek(3, 0, SEEK_CUR)                   = -1 ESPIPE (Illegal seek)
ioctl(3, SNDCTL_TMR_TIMEBASE or TCGETS, 0x7fff6ffa3460) = -1 EINVAL (Invalid argument)
lseek(3, 0, SEEK_CUR)                   = -1 ESPIPE (Illegal seek)
fcntl(3, F_SETFD, FD_CLOEXEC)           = 0
connect(3, {sa_family=AF_INET, sin_port=htons(11211), sin_addr=inet_addr("127.0.0.1")}, 16) = 0
write(3, "stats\r\n", 7)                = 7
read(3, 
For the moment I downgrade to version 1.4.22-4.el6.art which works just fine.
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: Latest memcached gives a lot of problem

Unread post by scott »

1.2.24 is up now, let us know if that covers it. Thanks!
Gazoo
New Forum User
New Forum User
Posts: 1
Joined: Mon Apr 27, 2015 5:34 am
Location: Edmonton

Re: Latest memcached gives a lot of problem

Unread post by Gazoo »

Unfortunately the issue is still present in memcached-1.4.24-5. I had to downgrade back to memcached-1.4.22-4 to get things working again.
Post Reply