problem with atomic-php70-php-devel

General Discussion of atomic repo and development projects.

Ask for help here with anything else not covered by other forums.
danliker
Forum User
Forum User
Posts: 16
Joined: Wed Jul 22, 2009 4:43 am

problem with atomic-php70-php-devel

Unread post by danliker »

looks like there is a problem with atomic-php70-php-devel:

# rpm -qi atomic-php70-php-devel
warning: Macro %atomic needs whitespace before body
warning: Macro %atomic needs whitespace before body
warning: Macro %atomic needs whitespace before body
warning: Macro %atomic needs whitespace before body
warning: Macro %atomic needs whitespace before body
warning: Macro %atomic needs whitespace before body
warning: Macro %atomic needs whitespace before body
warning: Macro %atomic needs whitespace before body
Name : atomic-php70-php-devel
Version : 7.0.0
Release : 0.15.rc1.el7.art
Architecture: x86_64
Install Date: Sat 29 Aug 2015 05:47:11 PM CEST
Group : Development/Libraries
Size : 4705390
License : PHP and Zend and BSD
Signature : RSA/SHA1, Sat 22 Aug 2015 07:49:07 PM CEST, Key ID ffbd5d0a4520afa9
Source RPM : atomic-php70-php-7.0.0-0.15.rc1.el7.art.src.rpm
Build Date : Sat 22 Aug 2015 07:48:50 PM CEST
Build Host : loggerhead.atomicorp.com
Relocations : (not relocatable)
URL : http://www.php.net/
Summary : Files needed for building PHP extensions
Description :
The atomic-php70-php-devel package contains the files needed for building PHP
extensions. If you need to compile your own PHP extensions, you will
need to install this package.
spyderz
New Forum User
New Forum User
Posts: 2
Joined: Sun Aug 30, 2015 5:03 am
Location: Las Vegas

Re: problem with atomic-php70-php-devel

Unread post by spyderz »

I don't know what happened, but after I install php-panda every time I use Yum or RPM I get
[root@server downloads]# yum clean all
warning: Macro %atomic needs whitespace before body
warning: Macro %atomic needs whitespace before body
warning: Macro %atomic needs whitespace before body
warning: Macro %atomic needs whitespace before body
warning: Macro %atomic needs whitespace before body
warning: Macro %atomic needs whitespace before body
warning: Macro %atomic needs whitespace before body
warning: Macro %atomic needs whitespace before body
Loaded plugins: fastestmirror
Cleaning repos: atomic base epel extras newrelic updates
Cleaning up everything
Cleaning up list of fastest mirrors
I tried removing the Atomic repo, cleaned everything and the error still persists. It kind of bungs up other things, like Plesk's GUI installer for components.
spyderz
New Forum User
New Forum User
Posts: 2
Joined: Sun Aug 30, 2015 5:03 am
Location: Las Vegas

Re: problem with atomic-php70-php-devel

Unread post by spyderz »

I used rpm -e nodeps to the offending package and it's gotten ridden of the problem for now.
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: problem with atomic-php70-php-devel

Unread post by scott »

Ive been looking into this one. Basically the newer rpm versions dont accept a "-" in a variable field. Older versions do
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: problem with atomic-php70-php-devel

Unread post by scott »

Of course I post that right when I think Im running into a wall, and then find a way around it immediately thereafter.... New version is up!
Post Reply