Problem with recent php updates in atomic repo

General Discussion of atomic repo and development projects.

Ask for help here with anything else not covered by other forums.
lfenison
Forum User
Forum User
Posts: 29
Joined: Mon Jun 14, 2010 8:39 pm

Problem with recent php updates in atomic repo

Unread post by lfenison »

I just ran yum update and seem to have dependency issues. I have never been any good at working around these kind of problems and was hoping someone could tell me how to get around this.

I use mysqlnd and libmcrypt and they seem to be the issue.

Code: Select all

> yum update
Loaded plugins: fastestmirror, priorities, refresh-packagekit, security
Setting up Update Process
Loading mirror speeds from cached hostfile
 * asl-4.0: www2.atomicorp.com
 * atomic: www2.atomicorp.com
 * base: mirrors.unifiedlayer.com
 * extras: mirror.spro.net
 * tortix: www2.atomicorp.com
 * updates: mirror.fusioncloud.co
518 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package php-mcrypt.x86_64 0:5.4.45-51.el6.art will be updated
---> Package php-mcrypt.x86_64 0:5.4.45-52.el6.art will be an update
--> Processing Dependency: php-common(x86-64) = 5.4.45-52.el6.art for package: php-mcrypt-5.4.45-52.el6.art.x86_64
---> Package php-mysqlnd.x86_64 0:5.4.45-51.el6.art will be updated
---> Package php-mysqlnd.x86_64 0:5.4.45-52.el6.art will be an update
--> Processing Dependency: php-pdo(x86-64) = 5.4.45-52.el6.art for package: php-mysqlnd-5.4.45-52.el6.art.x86_64
--> Finished Dependency Resolution
Error: Package: php-mysqlnd-5.4.45-52.el6.art.x86_64 (atomic)
           Requires: php-pdo(x86-64) = 5.4.45-52.el6.art
           Installed: php-pdo-5.4.45-51.el6.art.x86_64 (@atomic)
               php-pdo(x86-64) = 5.4.45-51.el6.art
           Available: php-pdo-5.3.3-40.el6_6.x86_64 (base)
               php-pdo(x86-64) = 5.3.3-40.el6_6
           Available: php-pdo-5.3.3-46.el6_6.x86_64 (updates)
               php-pdo(x86-64) = 5.3.3-46.el6_6
Error: Package: php-mcrypt-5.4.45-52.el6.art.x86_64 (atomic)
           Requires: php-common(x86-64) = 5.4.45-52.el6.art
           Installed: php-common-5.4.45-51.el6.art.x86_64 (@atomic)
               php-common(x86-64) = 5.4.45-51.el6.art
           Available: php-common-5.3.3-40.el6_6.x86_64 (base)
               php-common(x86-64) = 5.3.3-40.el6_6
           Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
               php-common(x86-64) = 5.3.3-46.el6_6
 You could try using --skip-broken to work around the problem
Does anyone have any clues what to do next?
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: Problem with recent php updates in atomic repo

Unread post by scott »

I think you might have hit a mirror still syncing or something. Regardless there is a -53 now that covers 2 more vulnerabilities. Make sure you clear your cache!
lfenison
Forum User
Forum User
Posts: 29
Joined: Mon Jun 14, 2010 8:39 pm

Re: Problem with recent php updates in atomic repo

Unread post by lfenison »

scott wrote:I think you might have hit a mirror still syncing or something. Regardless there is a -53 now that covers 2 more vulnerabilities. Make sure you clear your cache!
The new version didn't help either. I had to do a --skip-broken to get it to install but the same items had the same problems.

Code: Select all

Resolving Dependencies
--> Running transaction check
---> Package php-mcrypt.x86_64 0:5.4.45-51.el6.art will be updated
---> Package php-mcrypt.x86_64 0:5.4.45-53.el6.art will be an update
--> Processing Dependency: php-common(x86-64) = 5.4.45-53.el6.art for package: php-mcrypt-5.4.45-53.el6.art.x86_64
---> Package php-mysqlnd.x86_64 0:5.4.45-51.el6.art will be updated
---> Package php-mysqlnd.x86_64 0:5.4.45-53.el6.art will be an update
--> Processing Dependency: php-pdo(x86-64) = 5.4.45-53.el6.art for package: php-mysqlnd-5.4.45-53.el6.art.x86_64
--> Finished Dependency Resolution
Error: Package: php-mysqlnd-5.4.45-53.el6.art.x86_64 (atomic)
           Requires: php-pdo(x86-64) = 5.4.45-53.el6.art
           Installed: php-pdo-5.4.45-51.el6.art.x86_64 (@atomic)
               php-pdo(x86-64) = 5.4.45-51.el6.art
           Available: php-pdo-5.3.3-40.el6_6.x86_64 (base)
               php-pdo(x86-64) = 5.3.3-40.el6_6
           Available: php-pdo-5.3.3-46.el6_6.x86_64 (updates)
               php-pdo(x86-64) = 5.3.3-46.el6_6
Error: Package: php-mcrypt-5.4.45-53.el6.art.x86_64 (atomic)
           Requires: php-common(x86-64) = 5.4.45-53.el6.art
           Installed: php-common-5.4.45-51.el6.art.x86_64 (@atomic)
               php-common(x86-64) = 5.4.45-51.el6.art
           Available: php-common-5.3.3-40.el6_6.x86_64 (base)
               php-common(x86-64) = 5.3.3-40.el6_6
           Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
               php-common(x86-64) = 5.3.3-46.el6_6
 You could try using --skip-broken to work around the problem
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: Problem with recent php updates in atomic repo

Unread post by scott »

try adding --disableexcludes=all
lfenison
Forum User
Forum User
Posts: 29
Joined: Mon Jun 14, 2010 8:39 pm

Re: Problem with recent php updates in atomic repo

Unread post by lfenison »

scott wrote:try adding --disableexcludes=all
Same problem. Here is the result.

Code: Select all

 > yum update --disableexcludes=all
Loaded plugins: fastestmirror, priorities, refresh-packagekit, security
Setting up Update Process
Loading mirror speeds from cached hostfile
 * asl-4.0: www2.atomicorp.com
 * atomic: www2.atomicorp.com
 * base: mirror.pac-12.org
 * extras: mirrors.kernel.org
 * tortix: www2.atomicorp.com
 * updates: mirrors.xmission.com
570 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package php-mcrypt.x86_64 0:5.4.45-51.el6.art will be updated
---> Package php-mcrypt.x86_64 0:5.4.45-53.el6.art will be an update
--> Processing Dependency: php-common(x86-64) = 5.4.45-53.el6.art for package: php-mcrypt-5.4.45-53.el6.art.x86_64
---> Package php-mysqlnd.x86_64 0:5.4.45-51.el6.art will be updated
---> Package php-mysqlnd.x86_64 0:5.4.45-53.el6.art will be an update
--> Processing Dependency: php-pdo(x86-64) = 5.4.45-53.el6.art for package: php-mysqlnd-5.4.45-53.el6.art.x86_64
--> Finished Dependency Resolution
Error: Package: php-mysqlnd-5.4.45-53.el6.art.x86_64 (atomic)
           Requires: php-pdo(x86-64) = 5.4.45-53.el6.art
           Installed: php-pdo-5.4.45-51.el6.art.x86_64 (@atomic)
               php-pdo(x86-64) = 5.4.45-51.el6.art
           Available: php-pdo-5.3.3-40.el6_6.x86_64 (base)
               php-pdo(x86-64) = 5.3.3-40.el6_6
           Available: php-pdo-5.3.3-46.el6_6.x86_64 (updates)
               php-pdo(x86-64) = 5.3.3-46.el6_6
Error: Package: php-mcrypt-5.4.45-53.el6.art.x86_64 (atomic)
           Requires: php-common(x86-64) = 5.4.45-53.el6.art
           Installed: php-common-5.4.45-51.el6.art.x86_64 (@atomic)
               php-common(x86-64) = 5.4.45-51.el6.art
           Available: php-common-5.3.3-40.el6_6.x86_64 (base)
               php-common(x86-64) = 5.3.3-40.el6_6
           Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
               php-common(x86-64) = 5.3.3-46.el6_6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
biggles
Forum Regular
Forum Regular
Posts: 806
Joined: Tue Jul 15, 2008 2:38 pm
Location: Sweden
Contact:

Re: Problem with recent php updates in atomic repo

Unread post by biggles »

I'm having the same problem.

3.2.69-81.art.x86_64 #1 SMP Wed Jul 15 23:07:24 EDT 2015 x86_64 x86_64 x86_64 GNU/Linux

Atomic Secured Linux, version 4.0.17-34.el6.art: CentOS 6 (SUPPORTED)
CentOS 6 (SUPPORTED)
Copyright Atomicorp 2015
All Rights Reserved.

Extended Version Information:

ASL_VERSION 4.0.17-33
APPINV_VERSION 201502271124
CLAMAV_VERSION 201601111245
GEOMAP_VERSION 201601111223
GRSEC_VERSION 0
MODSEC_VERSION 201601121731
OSSEC_VERSION 201601071733
WAF_DELAYED_VERSION 0
KERNEL_VERSION 0
lfenison
Forum User
Forum User
Posts: 29
Joined: Mon Jun 14, 2010 8:39 pm

Re: Problem with recent php updates in atomic repo

Unread post by lfenison »

We are both running the same version of CentOS. I am running on 3 systems with the same OS version and only one of the three systems has the problem.

Linux zeus.deltatechnicalservices.com 3.2.68-77.art.x86_64 #1 SMP Fri Apr 24 11:36:07 EDT 2015 x86_64 x86_64 x86_64 GNU/Linux


Atomic Secured Linux, version 4.0.17-34.el6.art: CentOS 6 (SUPPORTED)
CentOS 6 (SUPPORTED)
Copyright Atomicorp 2015
All Rights Reserved.

Extended Version Information:

ASL_VERSION 4.0.17-33
APPINV_VERSION 201502271124
CLAMAV_VERSION 201601141535
GEOMAP_VERSION 201601141313
GRSEC_VERSION 0
MODSEC_VERSION 201601141536
OSSEC_VERSION 201601151410
WAF_DELAYED_VERSION 0
KERNEL_VERSION 0
lfenison
Forum User
Forum User
Posts: 29
Joined: Mon Jun 14, 2010 8:39 pm

Re: Problem with recent php updates in atomic repo

Unread post by lfenison »

scott wrote:try adding --disableexcludes=all
No luck with this.. Still won't install. Any ideas?

Code: Select all

 yum update --disableexcludes=all
Loaded plugins: fastestmirror, priorities, refresh-packagekit, security
Setting up Update Process
Loading mirror speeds from cached hostfile
 * asl-4.0: www3.atomicorp.com
 * atomic: www3.atomicorp.com
 * base: mirror.spro.net
 * extras: mirror.tocici.com
 * tortix: www3.atomicorp.com
 * updates: mirror.supremebytes.com
570 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package php-mcrypt.x86_64 0:5.4.45-51.el6.art will be updated
---> Package php-mcrypt.x86_64 0:5.4.45-53.el6.art will be an update
--> Processing Dependency: php-common(x86-64) = 5.4.45-53.el6.art for package: php-mcrypt-5.4.45-53.el6.art.x86_64
---> Package php-mysqlnd.x86_64 0:5.4.45-51.el6.art will be updated
---> Package php-mysqlnd.x86_64 0:5.4.45-53.el6.art will be an update
--> Processing Dependency: php-pdo(x86-64) = 5.4.45-53.el6.art for package: php-mysqlnd-5.4.45-53.el6.art.x86_64
--> Finished Dependency Resolution
Error: Package: php-mysqlnd-5.4.45-53.el6.art.x86_64 (atomic)
           Requires: php-pdo(x86-64) = 5.4.45-53.el6.art
           Installed: php-pdo-5.4.45-51.el6.art.x86_64 (@atomic)
               php-pdo(x86-64) = 5.4.45-51.el6.art
           Available: php-pdo-5.3.3-40.el6_6.x86_64 (base)
               php-pdo(x86-64) = 5.3.3-40.el6_6
           Available: php-pdo-5.3.3-46.el6_6.x86_64 (updates)
               php-pdo(x86-64) = 5.3.3-46.el6_6
Error: Package: php-mcrypt-5.4.45-53.el6.art.x86_64 (atomic)
           Requires: php-common(x86-64) = 5.4.45-53.el6.art
           Installed: php-common-5.4.45-51.el6.art.x86_64 (@atomic)
               php-common(x86-64) = 5.4.45-51.el6.art
           Available: php-common-5.3.3-40.el6_6.x86_64 (base)
               php-common(x86-64) = 5.3.3-40.el6_6
           Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
               php-common(x86-64) = 5.3.3-46.el6_6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Post Reply