Openvas install broken dependencies

General Discussion of atomic repo and development projects.

Ask for help here with anything else not covered by other forums.
pogito
New Forum User
New Forum User
Posts: 1
Joined: Tue Dec 05, 2017 9:59 am
Location: USA

Openvas install broken dependencies

Unread post by pogito »

Tried to install openvas after adding atomic repo. A few months ago I installed and everything worked. Trying to rebuild a new server for testing and it seems like Im getting an error for dependencies. Anything happen from last month till now?

---> Package gvm-tools.noarch 0:1.2.0-2781.el7.art will be installed
--> Processing Dependency: python(abi) = 3.4 for package: gvm-tools-1.2.0-2781.el7.art.noarch
--> Processing Dependency: python34-paramiko for package: gvm-tools-1.2.0-2781.el7.art.noarch
--> Processing Dependency: /usr/bin/python3.4 for package: gvm-tools-1.2.0-2781.el7.art.noarch
---> Package texlive-attachfile.noarch 2:svn21866.v1.5b-38.el7 will be installed
---> Package texlive-pst-math.noarch 2:svn20176.0.61-38.el7 will be installed
---> Package texlive-varwidth.noarch 2:svn24104.0.92-38.el7 will be installed
--> Processing Dependency: /usr/bin/python3.4 for package: gvm-tools-1.2.0-2781.el7.art.noarch
--> Finished Dependency Resolution
Error: Package: gvm-tools-1.2.0-2781.el7.art.noarch (atomic)
Requires: python34-paramiko
Error: Package: gvm-tools-1.2.0-2781.el7.art.noarch (atomic)
Requires: /usr/bin/python3.4
Error: Package: gvm-tools-1.2.0-2781.el7.art.noarch (atomic)
Requires: python(abi) = 3.4
Installed: python-2.7.5-58.el7.x86_64 (@anaconda)
python(abi) = 2.7
python(abi) = 2.7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

System Information:
Linux localhost.localdomain 3.10.0-693.el7.x86_64 #1 SMP Tue Aug 22 21:09:27 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
Centos 7 (minimal iso)

Thanks in advance
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: Openvas install broken dependencies

Unread post by scott »

That gvm-tools package is planned for a newer release, on el7 it gets complicated because of the python 3 dependencies. Its disabled in the EL7 (centos/rhel) repos and active in the Fedora ones. The update on your platform is:

openvas-9.0.0-2796

All this is fixable on EL7, we just need to get some of the python34 libraries built up for Centos/RHEL to support it.
Post Reply