store | blogs | forums | twitter | facebook | wiki | downloads | support portal
Atomic Secure Linux
It is currently Fri Dec 14, 2018 8:04 pm

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: aum not working with CentOS 7
Unread postPosted: Mon Oct 30, 2017 12:33 am 
Offline
Forum User
Forum User

Joined: Wed Nov 13, 2013 1:25 pm
Posts: 14
Location: t-dot
Trying to install aum with CentOS7 on cPanel with EA4.

as per your instructions

root@vps [~]# wget -q -O - https://updates.atomicorp.com/installers/aum

. . .

root@vps [~]# aum configure
-bash: aum: command not found

Any advice would be appreciated.
Thanks.


Top
 Profile  
Reply with quote  
 Post subject: Re: aum not working with CentOS 7
Unread postPosted: Mon Oct 30, 2017 11:49 am 
Offline
Forum User
Forum User

Joined: Wed Nov 13, 2013 1:25 pm
Posts: 14
Location: t-dot
Those lock icons in the wiki are confusing. Made me leave off the end part of the command.

Image

works when you use
Code:
wget -q -O - https://updates.atomicorp.com/installers/aum |bash


now to try to understand the cPanel config instructions


Top
 Profile  
Reply with quote  
 Post subject: Re: aum not working with CentOS 7
Unread postPosted: Mon Oct 30, 2017 1:10 pm 
Offline
Forum User
Forum User

Joined: Wed Nov 13, 2013 1:25 pm
Posts: 14
Location: t-dot
Can you tell me if I configure aum to install and update rules only, then what configuration steps do I need to take to make sure the rules are being processed in cPanel?

Thanks.


Top
 Profile  
Reply with quote  
 Post subject: Re: aum not working with CentOS 7
Unread postPosted: Mon Oct 30, 2017 3:31 pm 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
User avatar

Joined: Thu Feb 07, 2008 7:49 pm
Posts: 4066
Location: Chantilly, VA
aum will configure modsecurity automatically so whatever web server you are running it will take care of getting modsecurity installed, configured and running correctly.

_________________
Michael Shinn
Atomicorp - Security For Everyone


Top
 Profile  
Reply with quote  
 Post subject: Re: aum not working with CentOS 7
Unread postPosted: Mon Oct 30, 2017 3:39 pm 
Offline
Forum User
Forum User

Joined: Wed Nov 13, 2013 1:25 pm
Posts: 14
Location: t-dot
Thanks Mike.

Perhaps you can tell me this.

If aum has installed mod_security, etc.,
When I build a profile with Easy Apache 4 it has a switch for cPanel's version of mod_security.
Do I need to disable that to not overwrite your version?

Does this same logic apply to any other software?


Top
 Profile  
Reply with quote  
 Post subject: Re: aum not working with CentOS 7
Unread postPosted: Tue Oct 31, 2017 6:56 pm 
Offline
Forum User
Forum User

Joined: Wed Nov 13, 2013 1:25 pm
Posts: 14
Location: t-dot
Also one other question in addition to above.

Is aum supposed to install some GUI for cPanel?
I have no indication that any rules are being processed, except for Apache error logs.


Top
 Profile  
Reply with quote  
 Post subject: Re: aum not working with CentOS 7
Unread postPosted: Sat Nov 11, 2017 4:24 pm 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
User avatar

Joined: Thu Feb 07, 2008 7:49 pm
Posts: 4066
Location: Chantilly, VA
You will not want to use cpanels older version of modsecurity. Allow aum to handle all of this for you.

The gui is available in ASL.

_________________
Michael Shinn
Atomicorp - Security For Everyone


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group