Support for Ubuntu 20.04

Customer support forums for the modsecurity rules feed. There is no such thing as a bad question here as long as it pertains to using the real time modsecurity rules feed. Newbies feel free to get help getting started or asking questions that may be obvious.
DCCR
New Forum User
New Forum User
Posts: 1
Joined: Sat Oct 03, 2020 10:00 am
Location: DC

Support for Ubuntu 20.04

Unread post by DCCR »

I imagine this is similar with the CentOS 8 compatibility question. Plesk states:

Atomic (tortix) ModSecurity ruleset is not available because Atomic doesn’t support Ubuntu 20.04 yet;
https://support.plesk.com/hc/en-us/arti ... t-in-Plesk

However, on the CentOS question thread, it was noted, "The rules are supported on any platform that supports modsecurity, that includes Centos 8."

I would assume this is no different with Ubuntu 20.04. Is this compatibility issue with aum? If so, are there plans for 20.04 compatibility at some point?
User avatar
cponton
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 24
Joined: Fri Oct 09, 2020 9:41 am

Re: Support for Ubuntu 20.04

Unread post by cponton »

DCCR wrote:I imagine this is similar with the CentOS 8 compatibility question. Plesk states:

Atomic (tortix) ModSecurity ruleset is not available because Atomic doesn’t support Ubuntu 20.04 yet;
https://support.plesk.com/hc/en-us/arti ... t-in-Plesk

However, on the CentOS question thread, it was noted, "The rules are supported on any platform that supports modsecurity, that includes Centos 8."

I would assume this is no different with Ubuntu 20.04. Is this compatibility issue with aum? If so, are there plans for 20.04 compatibility at some point?
You can install ModSec manually, but that is correct that aum is not yet compatible with Ubuntu 20. It is currently in development, but I do not have a solid eta. Yet. If you would like to manually install, you can see this wiki article for instructions:
https://wiki.atomicorp.com/wiki/index.p ... stallation
Post Reply