Yum upadte epel vs asl4

Customer support forums for the modsecurity rules feed. There is no such thing as a bad question here as long as it pertains to using the real time modsecurity rules feed. Newbies feel free to get help getting started or asking questions that may be obvious.
Kalimari
Forum Regular
Forum Regular
Posts: 526
Joined: Wed Jan 02, 2008 3:21 pm
Location: United Kingdom

Yum upadte epel vs asl4

Unread post by Kalimari »

Just noticed a yum update for clamav which is pulling in the epel repo and obsoleting clamav-db from asl-4.0

Code: Select all

yum check-update
clamav-data.noarch                                                                0.101.4-1.el7                                                                    epel   
Obsoleting Packages
clamav-db.x86_64                                                                  0.101.4-8677.el7.art                                                             asl-4.0
    clamav-data.noarch                                                            0.101.3-1.el7                                                                    @epel 
Is it best to utilise yum-plugin-priorities package for this or is there a better solution.
Thanks
Imaging
Forum Regular
Forum Regular
Posts: 333
Joined: Sat Sep 25, 2010 2:46 pm

Re: Yum upadte epel vs asl4

Unread post by Imaging »

We add an exclude statement under [epel] in our epel.repo file. For example:

exclude=clamav* clamd

to keep the versions/repos from conflicting so that the asl versions will be the primary versions.
Post Reply