Support CentOS 8?

Customer support forums for the modsecurity rules feed. There is no such thing as a bad question here as long as it pertains to using the real time modsecurity rules feed. Newbies feel free to get help getting started or asking questions that may be obvious.
Azurel
Forum User
Forum User
Posts: 7
Joined: Fri Apr 24, 2020 5:17 am
Location: Germany

Support CentOS 8?

Unread post by Azurel »

Is here a roadmap to support CentOS 8?
User avatar
mikeshinn
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 4132
Joined: Thu Feb 07, 2008 7:49 pm
Location: Chantilly, VA

Re: Support CentOS 8?

Unread post by mikeshinn »

The rules are supported on any platform that supports modsecurity, that includes Centos 8.
Azurel
Forum User
Forum User
Posts: 7
Joined: Fri Apr 24, 2020 5:17 am
Location: Germany

Re: Support CentOS 8?

Unread post by Azurel »

Then I do not understand the point here.
Atomic did not yet release their ModSecurity rules compatible with CentOS 8/RHEL 8, since it is not available for selection at Tools & Settings > Web Application Firewall > Settings.
Source: https://support.plesk.com/hc/en-us/arti ... 0024962094
User avatar
mikeshinn
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 4132
Joined: Thu Feb 07, 2008 7:49 pm
Location: Chantilly, VA

Re: Support CentOS 8?

Unread post by mikeshinn »

We cant speak for Plesk, they may have their own process for installing and configuring modsecurity, but modsecurity rules are not platform dependant. Simply load the rules into modsecurity on whatever platform you are using and theyll work.
pdpete13
New Forum User
New Forum User
Posts: 4
Joined: Thu May 14, 2020 8:57 am
Location: DK

Re: Support CentOS 8?

Unread post by pdpete13 »

Unfortunatly this is correct.
CentOS 8 is supported - however "aum" does not support other than EL5, EL6, EL7.

https://updates.atomicorp.com/installers/aum

As Plesk are basing the ModSec "system" on the aum script, we are not able to use Atomicorp rules (not the advanced paid rules) with the Plesk / CentOS 8 setup.
User avatar
mikeshinn
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 4132
Joined: Thu Feb 07, 2008 7:49 pm
Location: Chantilly, VA

Re: Support CentOS 8?

Unread post by mikeshinn »

You can however install the rules on your server outside of Plesk, just follow this process:

https://wiki.atomicorp.com/wiki/index.p ... stallation
pdpete13
New Forum User
New Forum User
Posts: 4
Joined: Thu May 14, 2020 8:57 am
Location: DK

Re: Support CentOS 8?

Unread post by pdpete13 »

mikeshinn wrote:You can however install the rules on your server outside of Plesk, just follow this process:

https://wiki.atomicorp.com/wiki/index.p ... stallation
Hi Michael,
While this is true, i don't think we can use them with our Plesk-purchased license of the Advanced Atomicorp Security Rules. Seems this might only be available if the license is purchased directly from Atomicorp.
User avatar
mikeshinn
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 4132
Joined: Thu Feb 07, 2008 7:49 pm
Location: Chantilly, VA

Re: Support CentOS 8?

Unread post by mikeshinn »

I'm not sure if Plesk makes the rules available in some other way, but if they provided you with a username and password you can just log into our rules archive with those credentials and download the rules.
Azurel
Forum User
Forum User
Posts: 7
Joined: Fri Apr 24, 2020 5:17 am
Location: Germany

Re: Support CentOS 8?

Unread post by Azurel »

Thanks pdpete13

Here https://wiki.atomicorp.com/wiki/index.php/Aum its said supported only "centos 5/6".
Is here a schedule, when AUM will be supported in centOS 8?
I want use Advanced ModSecurity Rules by Atomicorp on my next server with CentOS 8.2.

EDIT: No answer, but wiki was changed to "centos 6/7"
User avatar
mikeshinn
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 4132
Joined: Thu Feb 07, 2008 7:49 pm
Location: Chantilly, VA

Re: Support CentOS 8?

Unread post by mikeshinn »

EL8 is officially supported.
Post Reply