Plesk 12 and multi PHP support

Community support for Plesk, CPanel, WebMin and others with insight from two of the founders of Plesk. Ask for help here! No question is too simple or complicated. :-)
hostingguy
Forum Regular
Forum Regular
Posts: 661
Joined: Mon Oct 29, 2007 6:51 pm

Plesk 12 and multi PHP support

Unread post by hostingguy »

Hi everyone,

I am new to Plesk 12 and the concept of the multi php is cool, and while exploring it more it appears that all of the alternatives offered are from plesk themselves.
Is there an option (and if so how?) to use atomic packages for 5.3, 5.4, 5.5, etc that come with the hardened options (like suhosin, etc) built in?

Also, does each one of these use a different php.ini file, or do they all share the same /etc/php.ini and /etc/php.d files?
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: Plesk 12 and multi PHP support

Unread post by scott »

Yeah they all use separate php.ini files under /opt/atomic/atomic-phpXX/. They're designed to co-exist with other installs concurrently, there isn't any kind of overlap and they wouldnt replace another php install on the system
hostingguy
Forum Regular
Forum Regular
Posts: 661
Joined: Mon Oct 29, 2007 6:51 pm

Re: Plesk 12 and multi PHP support

Unread post by hostingguy »

Hi Scott,

How do those get installed?
I followed the Plesk installer and it looks like it installed all of their versions - I have

plesk-php52-*
plesk-php53-*
plesk-php54-*
plesk-php55-*
plesk-php56-*

Those are in addition to the CloudLinux php-* packages - so Im not sure what to change to get this going to your guys php builds.

Do you have any guides for the plesk 12 noobie?
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: Plesk 12 and multi PHP support

Unread post by scott »

Sure, I did a thread for this just for plesk here:

http://forum.odin.com/threads/php-panda ... sk.293750/

Heres the TL;DR version:

Installation:

1) Set up the atomic yum repository

wget -q -O - http://www.atomicorp.com/installers/atomic |sh

2) Install the Panda

yum install plesk-php-panda

3) (Nucleus subscribers)
yum install plesk-php53-panda plesk-php52-panda
Post Reply