php-fpm 5.4.38 on CentOS 7 systemd launch script issue

Support/Development for PHP
jas8522
Forum User
Forum User
Posts: 52
Joined: Mon Jan 09, 2006 4:02 pm

php-fpm 5.4.38 on CentOS 7 systemd launch script issue

Unread post by jas8522 »

It appears that the 5.4.38 update has bundled in a php54 optional installation systemd launch script file for php-fpm on CentOS7. After updating to 5.4.38 on a Plesk 12 CentOS 7 box, these are the contents of my /usr/lib/systemd/system/php-fpm.service file:

Code: Select all

[Unit]
Description=The PHP FastCGI Process Manager
After=syslog.target network.target

[Service]
Type=notify
PIDFile=/run/php-fpm/php-fpm.pid
EnvironmentFile=/opt/atomic/atomic-php54/root/etc/sysconfig/atomic-php54-php-fpm
ExecStart=/opt/atomic/atomic-php54/root/usr/sbin/php-fpm --nodaemonize
ExecReload=/bin/kill -USR2 $MAINPID
PrivateTmp=true

[Install]
WantedBy=multi-user.target
Yet PHP 5.4 is still the live, updated system install for the server and is not installed in /opt at all. I suspect that systemd launch script shouldn't have been overwritten during this upgrade from the optional install versions of the php-fpm package.

This prevents php-fpm from starting entirely! Could use a rebuild :)
Last edited by jas8522 on Sun Mar 22, 2015 7:56 pm, edited 1 time in total.
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: php-fpm 5.4.38 on CentOS 7 systemd launch script issue

Unread post by scott »

Ok to be clear here, are we talking about atomic-php54 or php-5.4? They are two different packages.
jas8522
Forum User
Forum User
Posts: 52
Joined: Mon Jan 09, 2006 4:02 pm

Re: php-fpm 5.4.38 on CentOS 7 systemd launch script issue

Unread post by jas8522 »

I have this exact php-5.4 RPM installed, but it seems to install the systemd launch script from the atomic-php54 rpm in that it references binaries and configuration files in /opt and not the default system directories.

I should note that I accidentally mentioned above that I had updated to 5.4.39 when I meant I updated to 5.4.38 (this has now been edited in the original post).
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: php-fpm 5.4.38 on CentOS 7 systemd launch script issue

Unread post by scott »

latest versions are up, let me know if that resolves it for you. Thanks!
jas8522
Forum User
Forum User
Posts: 52
Joined: Mon Jan 09, 2006 4:02 pm

Re: php-fpm 5.4.38 on CentOS 7 systemd launch script issue

Unread post by jas8522 »

No such luck :(
# rpm -qa php-fpm
php-fpm-5.4.39-45.el7.art.x86_64
Note that it's not atomic-php54-php-fpm that's installed.

Contents of /lib/systemd/system/php-fpm.service:

Code: Select all

[Service]
Type=notify
PIDFile=/run/php-fpm/php-fpm.pid
EnvironmentFile=/opt/atomic/atomic-php54/root/etc/sysconfig/atomic-php54-php-fpm
ExecStart=/opt/atomic/atomic-php54/root/usr/sbin/php-fpm --nodaemonize
ExecReload=/bin/kill -USR2 $MAINPID
PrivateTmp=true
# ls -al /opt
total 8
drwxr-xr-x 2 root root 4096 Feb 1 00:49 .
drwxr-xr-x 18 root root 4096 Mar 23 18:29 ..
[root@base system]#
There's nothing installed in /opt, yet the systemd launch script is referencing the atomic-php54 packages for php-fpm.
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: php-fpm 5.4.38 on CentOS 7 systemd launch script issue

Unread post by scott »

SCL trickery is bleeding into the other package. They both come from the same src.rpm.
jas8522
Forum User
Forum User
Posts: 52
Joined: Mon Jan 09, 2006 4:02 pm

Re: php-fpm 5.4.38 on CentOS 7 systemd launch script issue

Unread post by jas8522 »

This is still an issue with 5.4.41-47

Are there plans to fix it? Or am I better off removing the atomicorp rpm as a default PHP install and instead using Plesk's version selector where (presumably) this isn't an issue?
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: php-fpm 5.4.38 on CentOS 7 systemd launch script issue

Unread post by scott »

Just included these in the latest PHP rollup of 5.4, 5.5 and 5.6. Could you grab those updates (this is specific to non-SCL php 5.4, which is included) and confirm the fix, and I'll sign this one off as closed.

Thanks again for the report, and apologies for not getting this out in a point release sooner.
jas8522
Forum User
Forum User
Posts: 52
Joined: Mon Jan 09, 2006 4:02 pm

Re: php-fpm 5.4.38 on CentOS 7 systemd launch script issue

Unread post by jas8522 »

Confirmed fixed with php-5.4.42-48.el7.art.x86_64.rpm

Thanks!

-Jordan
Post Reply