PHP 5.4.40, 5.5.24 and PHP 5.6.8

Support/Development for PHP
Imaging
Forum Regular
Forum Regular
Posts: 333
Joined: Sat Sep 25, 2010 2:46 pm

PHP 5.4.40, 5.5.24 and PHP 5.6.8

Unread post by Imaging »

FYI, PHP 5.4.40, 5.5.24 and PHP 5.6.8 are out:

http://php.net/archive/2015.php#id2015-04-16-3

with security fixes (in regards to updating the atomic repo and related packages).

Opcache has also been updated to 7.0.5:

https://pecl.php.net/package/ZendOpcache

Thanks.
Imaging
Forum Regular
Forum Regular
Posts: 333
Joined: Sat Sep 25, 2010 2:46 pm

Re: PHP 5.4.40, 5.5.24 and PHP 5.6.8

Unread post by Imaging »

Thanks for the quick updates for the base PHP.

As best we can see, the opcache update appears to be security related as well:

The 7.0.5 release mentioned:

Fixed bug #68677 (Use After Free in OPcache)

which appears to be the same as the bug report for the PHP included version:

https://bugs.php.net/bug.php?id=68677

so think the Atomic standalone opcache rpms like

php-pecl-zendopcache-7.0.3.1.el5.art

for example likely needs a security update.
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: PHP 5.4.40, 5.5.24 and PHP 5.6.8

Unread post by scott »

Last of the updates for this post should be hitting the repo shortly.
Imaging
Forum Regular
Forum Regular
Posts: 333
Joined: Sat Sep 25, 2010 2:46 pm

Re: PHP 5.4.40, 5.5.24 and PHP 5.6.8

Unread post by Imaging »

Thanks! (seeing the pecl package at 7.0.5)

One final question. For the atomic packages like:

atomic-php56-php-opcache-5.6.8-23.el5.art.x86_64

the version appears to be 7.0.4 (from /opt/atomic/atomic-php56/root/usr/bin/php -v).

Was said fix already backported for said packages?
Post Reply