Installing php-panda error: rpmts_HdrFromFdno: Header V4 R

Support/Development for PHP
JohnDingfors
New Forum User
New Forum User
Posts: 4
Joined: Tue Oct 27, 2015 8:21 am
Location: Sweden

Installing php-panda error: rpmts_HdrFromFdno: Header V4 R

Unread post by JohnDingfors »

Hello.

I am trying to install plesk-php-panda on CentOS 5 (PLESK 12.5). The packages for atomic-php54, atomic-php55 and plesk-php-panda are installed corretly and php-55 and php-56 show up and can be used in PLESK withput any problems.

But the atomic-php56 packages are not installed but ends with error "error: rpmts_HdrFromFdno: Header V4 R". Using --nogpgcheck I get a bit longer in the install process but it doesn't install the atomic-php56 packages and fails during the plesk-php-panda instead when it can't find the php56-binarys (see send quote below).

After some googling it seeams like CentOS5 doesn't support v4 signatues that the atomic-php56 packages are signed with. Can you resign them using v3 (the php54 and php55 seems to be signed usuing v3 but not the php-56?) or is there any way around this?

Thanks


[root@plesk10labb ~]# yum install plesk-php-panda
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* atomic: www6.atomicorp.com
* base: mirror.one.com
* extras: mirror.one.com
* updates: mirror.one.com
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package plesk-php-panda.i386 0:0.8-8.el5.art set to be updated
--> Processing Dependency: atomic-php56-php-xmlrpc for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-xml for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-tidy for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-soap for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-snmp for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-recode for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-pspell for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-process for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-pgsql for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-pdo for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-odbc for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-mysqlnd for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-mssql for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-mcrypt for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-mbstring for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-ldap for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-intl for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-interbase for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-imap for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-gmp for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-gd for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-fpm for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-enchant for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-devel for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-common for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-cli for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php-bcmath for package: plesk-php-panda
--> Processing Dependency: atomic-php56-php for package: plesk-php-panda
--> Running transaction check
---> Package atomic-php56-php.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-bcmath.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-cli.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-common.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-devel.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-enchant.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-fpm.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-gd.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-gmp.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-imap.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-interbase.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-intl.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-ldap.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-mbstring.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-mcrypt.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-mssql.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-mysqlnd.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-odbc.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-pdo.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-pgsql.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-process.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-pspell.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-recode.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-snmp.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-soap.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-tidy.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-xml.i386 0:5.6.14-29.el5.art set to be updated
---> Package atomic-php56-php-xmlrpc.i386 0:5.6.14-29.el5.art set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================================================================================================================================================
Package Arch Version Repository Size
=============================================================================================================================================================================================================================================
Installing:
plesk-php-panda i386 0.8-8.el5.art atomic 8.5 k
Installing for dependencies:
atomic-php56-php i386 5.6.14-29.el5.art atomic 3.4 M
atomic-php56-php-bcmath i386 5.6.14-29.el5.art atomic 49 k
atomic-php56-php-cli i386 5.6.14-29.el5.art atomic 3.3 M
atomic-php56-php-common i386 5.6.14-29.el5.art atomic 1.3 M
atomic-php56-php-devel i386 5.6.14-29.el5.art atomic 3.2 M
atomic-php56-php-enchant i386 5.6.14-29.el5.art atomic 31 k
atomic-php56-php-fpm i386 5.6.14-29.el5.art atomic 1.7 M
atomic-php56-php-gd i386 5.6.14-29.el5.art atomic 266 k
atomic-php56-php-gmp i386 5.6.14-29.el5.art atomic 53 k
atomic-php56-php-imap i386 5.6.14-29.el5.art atomic 82 k
atomic-php56-php-interbase i386 5.6.14-29.el5.art atomic 111 k
atomic-php56-php-intl i386 5.6.14-29.el5.art atomic 261 k
atomic-php56-php-ldap i386 5.6.14-29.el5.art atomic 61 k
atomic-php56-php-mbstring i386 5.6.14-29.el5.art atomic 1.2 M
atomic-php56-php-mcrypt i386 5.6.14-29.el5.art atomic 46 k
atomic-php56-php-mssql i386 5.6.14-29.el5.art atomic 67 k
atomic-php56-php-mysqlnd i386 5.6.14-29.el5.art atomic 347 k
atomic-php56-php-odbc i386 5.6.14-29.el5.art atomic 83 k
atomic-php56-php-pdo i386 5.6.14-29.el5.art atomic 116 k
atomic-php56-php-pgsql i386 5.6.14-29.el5.art atomic 142 k
atomic-php56-php-process i386 5.6.14-29.el5.art atomic 62 k
atomic-php56-php-pspell i386 5.6.14-29.el5.art atomic 30 k
atomic-php56-php-recode i386 5.6.14-29.el5.art atomic 25 k
atomic-php56-php-snmp i386 5.6.14-29.el5.art atomic 56 k
atomic-php56-php-soap i386 5.6.14-29.el5.art atomic 281 k
atomic-php56-php-tidy i386 5.6.14-29.el5.art atomic 53 k
atomic-php56-php-xml i386 5.6.14-29.el5.art atomic 281 k
atomic-php56-php-xmlrpc i386 5.6.14-29.el5.art atomic 86 k

Transaction Summary
=============================================================================================================================================================================================================================================
Install 29 Package(s)
Upgrade 0 Package(s)

Total download size: 17 M
Is this ok [y/N]: y
Downloading Packages:
(1/29): plesk-php-panda-0.8-8.el5.art.i386.rpm | 8.5 kB 00:00
(2/29): atomic-php56-php-recode-5.6.14-29.el5.art.i386.rpm | 25 kB 00:00
(3/29): atomic-php56-php-pspell-5.6.14-29.el5.art.i386.rpm | 30 kB 00:00
(4/29): atomic-php56-php-enchant-5.6.14-29.el5.art.i386.rpm | 31 kB 00:00
(5/29): atomic-php56-php-mcrypt-5.6.14-29.el5.art.i386.rpm | 46 kB 00:00
(6/29): atomic-php56-php-bcmath-5.6.14-29.el5.art.i386.rpm | 49 kB 00:00
(7/29): atomic-php56-php-tidy-5.6.14-29.el5.art.i386.rpm | 53 kB 00:00
(8/29): atomic-php56-php-gmp-5.6.14-29.el5.art.i386.rpm | 53 kB 00:00
(9/29): atomic-php56-php-snmp-5.6.14-29.el5.art.i386.rpm | 56 kB 00:00
(10/29): atomic-php56-php-ldap-5.6.14-29.el5.art.i386.rpm | 61 kB 00:00
(11/29): atomic-php56-php-process-5.6.14-29.el5.art.i386.rpm | 62 kB 00:00
(12/29): atomic-php56-php-mssql-5.6.14-29.el5.art.i386.rpm | 67 kB 00:00
(13/29): atomic-php56-php-imap-5.6.14-29.el5.art.i386.rpm | 82 kB 00:00
(14/29): atomic-php56-php-odbc-5.6.14-29.el5.art.i386.rpm | 83 kB 00:00
(15/29): atomic-php56-php-xmlrpc-5.6.14-29.el5.art.i386.rpm | 86 kB 00:00
(16/29): atomic-php56-php-interbase-5.6.14-29.el5.art.i386.rpm | 111 kB 00:00
(17/29): atomic-php56-php-pdo-5.6.14-29.el5.art.i386.rpm | 116 kB 00:00
(18/29): atomic-php56-php-pgsql-5.6.14-29.el5.art.i386.rpm | 142 kB 00:00
(19/29): atomic-php56-php-intl-5.6.14-29.el5.art.i386.rpm | 261 kB 00:00
(20/29): atomic-php56-php-gd-5.6.14-29.el5.art.i386.rpm | 266 kB 00:00
(21/29): atomic-php56-php-xml-5.6.14-29.el5.art.i386.rpm | 281 kB 00:00
(22/29): atomic-php56-php-soap-5.6.14-29.el5.art.i386.rpm | 281 kB 00:00
(23/29): atomic-php56-php-mysqlnd-5.6.14-29.el5.art.i386.rpm | 347 kB 00:00
(24/29): atomic-php56-php-mbstring-5.6.14-29.el5.art.i386.rpm | 1.2 MB 00:01
(25/29): atomic-php56-php-common-5.6.14-29.el5.art.i386.rpm | 1.3 MB 00:01
(26/29): atomic-php56-php-fpm-5.6.14-29.el5.art.i386.rpm | 1.7 MB 00:01
(27/29): atomic-php56-php-devel-5.6.14-29.el5.art.i386.rpm | 3.2 MB 00:01
(28/29): atomic-php56-php-cli-5.6.14-29.el5.art.i386.rpm | 3.3 MB 00:02
(29/29): atomic-php56-php-5.6.14-29.el5.art.i386.rpm | 3.4 MB 00:03
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total 563 kB/s | 17 MB 00:30
fel: rpmts_HdrFromFdno: Huvud V4 RSA/SHA1 signature: BAD, key ID 4520afa9


Problem opening package atomic-php56-php-imap-5.6.14-29.el5.art.i386.rpm

Using --nogpgcheck gets me longer but still fails at the end:
[2015-10-27 12:51:15] ERR [util_exec] proc_close() failed ['/usr/local/psa/admin/bin/php_handlers_control' '--add' '--path' '/opt/atomic/atomic-php56/root/usr/bin/php-cgi' '--phpini' '/opt/atomic/atomic-php56/root/etc/php.ini' '--type' 'fastcgi' '--displayname' 'Atomic 5.6' '--id' 'fastcgi-56' '--clipath' '/opt/atomic/atomic-php56/root/usr/bin/php'] with exit code [1]
Error occured while sending feedback. HTTP code returned: 502
Error occured while sending feedback. HTTP code returned: 502
Unable to register the PHP handler: Binary /opt/atomic/atomic-php56/root/usr/bin/php-cgi doesn't exists


Non-fatal POSTIN scriptlet failure in rpm package plesk-php-panda-0.8-8.el5.art.i386
fel: %post(plesk-php-panda-0.8-8.el5.art.i386) skript misslyckades, slutstatus 1
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: Installing php-panda error: rpmts_HdrFromFdno: Header V4

Unread post by scott »

Sorry I couldnt get around to this sooner, had a lot on my plate lately. It looks like that is related to one of the newer builders (fc22) making some funky packaging for el5. I've pushed out updated versions of those packages, so you might need to clear your cache and retry to get those.
JohnDingfors
New Forum User
New Forum User
Posts: 4
Joined: Tue Oct 27, 2015 8:21 am
Location: Sweden

Re: Installing php-panda error: rpmts_HdrFromFdno: Header V4

Unread post by JohnDingfors »

Thanks Scott.

It now installs smoothly onto Centos5 without any warnings. Again, thank you!
Post Reply