store | blogs | forums | twitter | facebook | wiki | downloads | support portal
Atomic Secure Linux
It is currently Wed Aug 21, 2019 3:03 am

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: MySQL update failed
Unread postPosted: Wed Nov 21, 2012 2:47 pm 
Offline
Forum User
Forum User

Joined: Wed Nov 21, 2012 2:38 pm
Posts: 5
Location: Kelowna, BC
Good Morning,

My Atomic Secured Linux Control Panel informed me that there was a new update and I used yum list updates to find that there was an update for MySQL server available. Everything went normally, as it has done before, except that this time, it gave me the following result:

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

[root@zeus ~]# yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* asl-3.0: www3.atomicorp.com
* atomic: www3.atomicorp.com
* base: mirror.its.sfu.ca
* extras: mirror.its.sfu.ca
* updates: mirror.its.sfu.ca
Excluding Packages in global exclude list
Finished
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package mysql.x86_64 0:5.5.28-13.el5.art set to be updated
---> Package mysql-libs.x86_64 0:5.5.28-13.el5.art set to be updated
---> Package mysql-server.x86_64 0:5.5.28-13.el5.art set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=====================================================================================================================================================================
Package Arch Version Repository Size
=====================================================================================================================================================================
Updating:
mysql x86_64 5.5.28-13.el5.art atomic 7.5 M
mysql-libs x86_64 5.5.28-13.el5.art atomic 1.1 M
mysql-server x86_64 5.5.28-13.el5.art atomic 13 M

Transaction Summary
=====================================================================================================================================================================
Install 0 Package(s)
Upgrade 3 Package(s)

Total download size: 21 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): mysql-libs-5.5.28-13.el5.art.x86_64.rpm | 1.1 MB 00:00
(2/3): mysql-5.5.28-13.el5.art.x86_64.rpm | 7.5 MB 00:01
(3/3): mysql-server-5.5.28-13.el5.art.x86_64.rpm | 13 MB 00:02
---------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total 3.4 MB/s | 21 MB 00:06
warning: rpmts_HdrFromFdno: Header V3 RSA/SHA1 signature: NOKEY, key ID 4520afa9
atomic/gpgkey | 1.3 kB 00:00


Public key for mysql-server-5.5.28-13.el5.art.x86_64.rpm is not installed

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

I have never seen that a public key was required, does anyone3 know what this is about and how to resolve this?

Thanks,
Peter


Top
 Profile  
Reply with quote  
 Post subject: Re: MySQL update failed
Unread postPosted: Wed Nov 21, 2012 5:52 pm 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
User avatar

Joined: Thu Feb 07, 2008 7:49 pm
Posts: 4082
Location: Chantilly, VA
You might have hit the mirrors while they were still syncing. So flush your cache and try again:

yum clean all

yum upgrade mysql

_________________
Michael Shinn
Atomicorp - Security For Everyone


Top
 Profile  
Reply with quote  
 Post subject: Re: MySQL update failed
Unread postPosted: Thu Nov 22, 2012 2:11 pm 
Offline
Forum User
Forum User

Joined: Wed Nov 21, 2012 2:38 pm
Posts: 5
Location: Kelowna, BC
I cleaned my cache and tried to upgrade mySQL. Apparently, there are no updates available now - neither when I use yum list updates nor are there any indicated on my Atomic Secured Linux CP ...


Top
 Profile  
Reply with quote  
 Post subject: Re: MySQL update failed
Unread postPosted: Thu Nov 22, 2012 10:35 pm 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
User avatar

Joined: Thu Feb 07, 2008 7:49 pm
Posts: 4082
Location: Chantilly, VA
What version is installed on your system? Perhaps you have yum setup to automatically update the system, or someone else updated it? 5.5.28-13 is the latest.

_________________
Michael Shinn
Atomicorp - Security For Everyone


Top
 Profile  
Reply with quote  
 Post subject: Re: MySQL update failed
Unread postPosted: Tue Jan 29, 2013 1:07 am 
Offline
Forum Regular
Forum Regular
User avatar

Joined: Wed Jan 13, 2010 9:11 am
Posts: 196
Location: Bali
I also have a MySQL Upgrade problem but not the "public key" issue listed above.
My issue is package conflict?
Code:
# yum upgrade mysql
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * asl-3.0: www3.atomicorp.com
 * atomic: www3.atomicorp.com
 * base: mirrors.sin3.sg.voxel.net
 * extras: mirrors.sin3.sg.voxel.net
 * updates: mirrors.sin3.sg.voxel.net
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: mysql = 5.1.54-1.el5.art for package: mysql-server
---> Package mysql.i386 0:5.5.29-14.el5.art set to be updated
--> Processing Dependency: mysql-libs = 5.5.29-14.el5.art for package: mysql
--> Running transaction check
---> Package mysql-libs.i386 0:5.5.29-14.el5.art set to be updated
---> Package mysql-server.i386 0:5.5.29-14.el5.art set to be updated
--> Processing Dependency: libaio.so.1(LIBAIO_0.4) for package: mysql-server
--> Processing Dependency: libaio.so.1 for package: mysql-server
--> Processing Dependency: libaio.so.1(LIBAIO_0.1) for package: mysql-server
--> Running transaction check
---> Package libaio.i386 0:0.3.106-5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

============================================================================================================================================================================================================
 Package                                            Arch                                       Version                                                   Repository                                    Size
============================================================================================================================================================================================================
Updating:
 mysql                                              i386                                       5.5.29-14.el5.art                                         atomic                                       7.6 M
Installing for dependencies:
 libaio                                             i386                                       0.3.106-5                                                 base                                          19 k
Updating for dependencies:
 mysql-libs                                         i386                                       5.5.29-14.el5.art                                         atomic                                       1.1 M
 mysql-server                                       i386                                       5.5.29-14.el5.art                                         atomic                                        13 M

Transaction Summary
============================================================================================================================================================================================================
Install       1 Package(s)
Upgrade       3 Package(s)

Total size: 22 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /usr/lib/mysql/libmysqlclient.so.18.0.0 from install of mysql-libs-5.5.29-14.el5.art.i386 conflicts with file from package mysqlclient18-5.5.28-6.el5.art.i386

Error Summary
-------------

# exit

_________________
They say that good intentions, pave the road to hell;
If a thing is not worth doing, it's not worth doing well.


Top
 Profile  
Reply with quote  
 Post subject: Re: MySQL update failed
Unread postPosted: Tue Jan 29, 2013 11:02 am 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin

Joined: Wed Dec 31, 1969 8:00 pm
Posts: 8329
Location: earth
You wouldnt need mysqlclient18 and mysql-libs-5.5.29. They're the same mysql 5.5 client library


Top
 Profile  
Reply with quote  
 Post subject: Re: MySQL update failed
Unread postPosted: Tue Jan 29, 2013 11:25 am 
Offline
Forum Regular
Forum Regular
User avatar

Joined: Wed Jan 13, 2010 9:11 am
Posts: 196
Location: Bali
Thank you for your reply.
How do I solve the conflict and upgrade MySQL?
Will this version of MySQL conflict with my current PHP Version: 5.2.17 or should I upgrade that first?

_________________
They say that good intentions, pave the road to hell;
If a thing is not worth doing, it's not worth doing well.


Top
 Profile  
Reply with quote  
 Post subject: Re: MySQL update failed
Unread postPosted: Tue Jan 29, 2013 6:09 pm 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin

Joined: Wed Dec 31, 1969 8:00 pm
Posts: 8329
Location: earth
Remove the mysqlclient18 package


Top
 Profile  
Reply with quote  
 Post subject: Re: MySQL update failed
Unread postPosted: Wed Jan 30, 2013 7:06 pm 
Offline
Forum Regular
Forum Regular
User avatar

Joined: Wed Jan 13, 2010 9:11 am
Posts: 196
Location: Bali
scott wrote:
Remove the mysqlclient18 package

See https://www.atomicorp.com/forum/viewtopic.php?f=1&t=5941 for follow-up on MySQL issues.

_________________
They say that good intentions, pave the road to hell;
If a thing is not worth doing, it's not worth doing well.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group