store | blogs | forums | twitter | facebook | wiki | downloads | support portal
Atomic Secure Linux
It is currently Sat Oct 19, 2019 6:45 pm

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: MySQL cant update, mysql-libs dependency problem
Unread postPosted: Wed Mar 19, 2014 7:07 pm 
Offline
Forum Regular
Forum Regular

Joined: Mon Oct 29, 2007 6:51 pm
Posts: 661
Yum doesn't seem to want to update mysql-libs from atomic.

Quote:
# yum update
Loaded plugins: allowdowngrade, changelog, downloadonly, fastestmirror, protectbase, rhnplugin
Loading mirror speeds from cached hostfile
* asl-3.0: www5.atomicorp.com
* atomic: www5.atomicorp.com
* cloudlinux-x86_64-server-5: cl.banahosting.com
Excluding Packages in global exclude list
Finished
Excluding Packages from Atomicorp - Atomic Secured Linux 3.0
Finished
Excluding Packages from CentOS / Red Hat Enterprise Linux 5 - atomicrocketturtle.com
Finished
Excluding Packages from Plesk Server Administrator
Finished
383 packages excluded due to repository protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: real-mysql-libs = 5.5.33-20.el5.art for package: mysql-server
--> Processing Dependency: real-mysql-libs = 5.5.33-20.el5.art for package: mysql
---> Package mysql-libs.x86_64 0:5.5.36-21.el5.art set to be updated
--> Processing Dependency: mysql = 5.5.36-21.el5.art for package: mysql-libs
--> Running transaction check
---> Package mysql-libs.i386 0:5.5.33-20.el5.art set to be updated
---> Package mysql-libs.x86_64 0:5.5.36-21.el5.art set to be updated
--> Processing Dependency: mysql = 5.5.36-21.el5.art for package: mysql-libs
--> Finished Dependency Resolution
mysql-libs-5.5.36-21.el5.art.x86_64 from atomic has depsolving problems
--> Missing Dependency: mysql = 5.5.36-21.el5.art is needed by package mysql-libs-5.5.36-21.el5.art.x86_64 (atomic)
Error: Missing Dependency: mysql = 5.5.36-21.el5.art is needed by package mysql-libs-5.5.36-21.el5.art.x86_64 (atomic)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest


# rpm -qa | grep mysql
php-mysql-5.3.27-20.el5.art.x86_64
asl-php-mysqlnd-5.4.24-22.el5.art.x86_64
mysqltuner-1.2.0-6.el5.art.noarch
ossec-hids-mysql-2.7.1-37.el5.art.x86_64
mysql-5.5.33-20.el5.art.x86_64
mysqlclient15-5.0.91-1.el5.1.x86_64
mysql-libs-5.5.33-20.el5.art.x86_64
mysqlclient16-5.1.59-2.el5.art.x86_64
ruby-mysql-2.7-200705221357.x86_64
mysql-server-5.5.33-20.el5.art.x86_64


Top
 Profile  
Reply with quote  
 Post subject: Re: MySQL cant update, mysql-libs dependency problem
Unread postPosted: Wed Mar 19, 2014 7:59 pm 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin

Joined: Wed Dec 31, 1969 8:00 pm
Posts: 8329
Location: earth
Any excludes, or priorities?


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group