GPG key mismatch, centos6 yum install

pmageau
New Forum User
New Forum User
Posts: 2
Joined: Mon Jun 08, 2015 8:09 am
Location: Ontario

GPG key mismatch, centos6 yum install

Unread post by pmageau »

I have some centos6 servers and lately I have been unable to install ossec-hids and ossec-hids-server using yum.

I do the following commands:
wget -q -O - http://www.atomicorp.com/installers/atomic | sh
yum clean all
yum install ossec-hids ossec-hids-server

Once I install, I get the following message (packages fail to install)
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY.art.txt
The GPG keys listed for the "CentOS / Red Hat Enterprise Linux 6 - atomicrocketturtle.com" repository are already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository.

This happened on Friday and now that we are Monday, I was hoping the problem would have been fixed by now. I have tried to uninstall atomic-release and re-run the commands to install and I still get the same error.
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: GPG key mismatch, centos6 yum install

Unread post by scott »

What version of atomic-release do you have installed? That looks like its not the right version
Imaging
Forum Regular
Forum Regular
Posts: 333
Joined: Sat Sep 25, 2010 2:46 pm

Re: GPG key mismatch, centos6 yum install

Unread post by Imaging »

I'd suspect the issue is likely with the packages themselves.

We're getting the same error.

We have the latest atomic release:

atomic-release-1.0-19.el6.art.noarch.rpm

Just as a double-check, a yum clean all and then yum install atomic-release shows the latest version installed with nothing to do.
pmageau
New Forum User
New Forum User
Posts: 2
Joined: Mon Jun 08, 2015 8:09 am
Location: Ontario

Re: GPG key mismatch, centos6 yum install

Unread post by pmageau »

Still have issue.
I delete atomic-release using the command: yum remove atomic-release
Then get the latest version by using this command (as documented):
wget -q -O - http://www.atomicorp.com/installers/atomic | sh

This install: atomic-release-1.0-18.el6.art.noarch.rpm
Imaging
Forum Regular
Forum Regular
Posts: 333
Joined: Sat Sep 25, 2010 2:46 pm

Re: GPG key mismatch, centos6 yum install

Unread post by Imaging »

This appears to have been fixed with the latest 2.8.2 packages. The error is no longer present (no changes on our end in regards to the keys).
Post Reply