error mod_security since this week end

Customer support forums for Atomic Protector (formerly Atomic Secured Linux). There is no such thing as a bad question here as long as it pertains to using Atomic Protector. Newbies feel free to get help getting started or asking questions that may be obvious. Regular users are asked to be gentle. :-)
heiny
Forum User
Forum User
Posts: 14
Joined: Fri May 20, 2016 12:24 pm
Location: Canada

error mod_security since this week end

Unread post by heiny »

Got this: 2 9901 ASLCommon::cmd_system ERROR: '/bin/cp -af /var/asl/rules/modsec/
template-* /var/asl/data/templates/ >/dev/
null 2>&1 (1)'
3 18 c_modsec::apply_rules Failed to copy file /var/asl/rules/modsec/
waf_classes -> /var/asl/data/waf_classes

When asl -s -f or aum -uf

When I ls -l /var/asl/rules/modsec/ I got :

-rw-rw-rw- 1 root root 0 Nov 21 11:43 10_asl_rules.conf

How can I get all rules back ?
User avatar
mikeshinn
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 4122
Joined: Thu Feb 07, 2008 7:49 pm
Location: Chantilly, VA

Re: error mod_security since this week end

Unread post by mikeshinn »

Whats the output of:

aum -uf
heiny
Forum User
Forum User
Posts: 14
Joined: Fri May 20, 2016 12:24 pm
Location: Canada

Re: error mod_security since this week end

Unread post by heiny »

2 9901 ASLCommon::cmd_system ERROR: '/bin/cp -af /var/asl/rules/modsec/
template-* /var/asl/data/templates/ >/dev/
null 2>&1 (1)'
3 18 c_modsec::apply_rules Failed to copy file /var/asl/rules/modsec/
waf_classes -> /var/asl/data/waf_classes
stealthtech1
New Forum User
New Forum User
Posts: 1
Joined: Sat Nov 26, 2016 7:55 am
Location: South Africa

Re: error mod_security since this week end

Unread post by stealthtech1 »

heiny, have you managed to fix this as i'm getting this exact same error and the output of my folders are the same.

Please let me know

thanks
heiny
Forum User
Forum User
Posts: 14
Joined: Fri May 20, 2016 12:24 pm
Location: Canada

Re: error mod_security since this week end

Unread post by heiny »

We didn't fix that yet.

We disabled mod_sec in ASL for now. I was supposed to open a ticket last week about that. Will do it today.
Post Reply