OpenVAS package broken - missing dependency

Support/Development for OpenVAS
Pellinor
New Forum User
New Forum User
Posts: 4
Joined: Tue Jul 07, 2015 2:33 pm
Location: Bethesda, MD

OpenVAS package broken - missing dependency

Unread post by Pellinor »

Hi,

I tried installing the latest OpenVAS package (from http://www.atomicorp.com/installers/atomic) on a RHEL 7.1 box and got the following error:


---> Package openvas-libraries.x86_64 0:8.0.3-19.el7.art will be installed
--> Processing Dependency: libksba.so.8(KSBA_0.9)(64bit) for package: openvas-libraries-8.0.3-19.el7.art.x86_64
--> Processing Dependency: libksba.so.8()(64bit) for package: openvas-libraries-8.0.3-19.el7.art.x86_64
---> Package texlive-attachfile.noarch 2:svn21866.v1.5b-32.el7 will be installed
---> Package texlive-pst-math.noarch 2:svn20176.0.61-32.el7 will be installed
---> Package texlive-varwidth.noarch 2:svn24104.0.92-32.el7 will be installed
--> Finished Dependency Resolution
Error: Package: openvas-libraries-8.0.3-19.el7.art.x86_64 (atomic)
Requires: libksba.so.8()(64bit)
Error: Package: openvas-libraries-8.0.3-19.el7.art.x86_64 (atomic)
Requires: libksba.so.8(KSBA_0.9)(64bit)


Any help would be much appreciated.
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: OpenVAS package broken - missing dependency

Unread post by scott »

Do you have a valid update subscription? That is from a distro provided package called libksba.
Pellinor
New Forum User
New Forum User
Posts: 4
Joined: Tue Jul 07, 2015 2:33 pm
Location: Bethesda, MD

Re: OpenVAS package broken - missing dependency

Unread post by Pellinor »

I'm not sure what you mean by an update subscription. I'm trying to do a fresh install of openvas on a newly spun up AWS VM. I install wget and mlocate, because they don't come pre-installed, then follow the instructions listed on the openvas website, but still get the missing dependency message.
User avatar
mikeshinn
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 4122
Joined: Thu Feb 07, 2008 7:49 pm
Location: Chantilly, VA

Re: OpenVAS package broken - missing dependency

Unread post by mikeshinn »

A valid RHEL 7.1 subscription. That packages is provided by Redhat. If you system doesnt have a valid subscription with them, they wont let you download packages.
Pellinor
New Forum User
New Forum User
Posts: 4
Joined: Tue Jul 07, 2015 2:33 pm
Location: Bethesda, MD

Re: OpenVAS package broken - missing dependency

Unread post by Pellinor »

because this is an Amazon VM I connect to their package library, but the contents seen the same as far as I can tell. Do you know the name of the package that contains that lib? I haven't been able to find it.
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: OpenVAS package broken - missing dependency

Unread post by scott »

Sure, on my system its called:

libksba-1.3.0-5.el7.x86_64
Pellinor
New Forum User
New Forum User
Posts: 4
Joined: Tue Jul 07, 2015 2:33 pm
Location: Bethesda, MD

Re: OpenVAS package broken - missing dependency

Unread post by Pellinor »

looks like they just don't have that lib. I'm going to throw together an ubuntu box for it instead, I guess, but thank you for all of your help.
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: OpenVAS package broken - missing dependency

Unread post by scott »

I know its in there, but perhaps not in the main rhel base repo (why, I do not know...). I know redhat makes it though. Maybe a "util" repo or something like that?
prupert
Forum Regular
Forum Regular
Posts: 573
Joined: Tue Aug 01, 2006 2:45 pm
Location: Netherlands

Re: OpenVAS package broken - missing dependency

Unread post by prupert »

libksba is in the base repo of RHEL 7.
Lemonbit Internet Dedicated Server Management
srak
New Forum User
New Forum User
Posts: 1
Joined: Wed Oct 21, 2015 4:21 pm
Location: Uruguay

Re: OpenVAS package broken - missing dependency

Unread post by srak »

You can try this, quick and dirty.
I have the same problem and manage to work it out, that way.
prupert
Forum Regular
Forum Regular
Posts: 573
Joined: Tue Aug 01, 2006 2:45 pm
Location: Netherlands

Re: OpenVAS package broken - missing dependency

Unread post by prupert »

srak wrote:You can try this, quick and dirty.
I have the same problem and manage to work it out, that way.
No, don't do that. That is an EL 6 package, not EL7. Also, the package is out-dated and from an unofficial repo that doesn't exist anymore.
Lemonbit Internet Dedicated Server Management
klund
New Forum User
New Forum User
Posts: 2
Joined: Mon Nov 28, 2016 1:17 pm
Location: Houston, Texas

Re: OpenVAS package broken - missing dependency

Unread post by klund »

prupert wrote:libksba is in the base repo of RHEL 7.
For what it's worth, in OracleLinux 7 (a RedHat derivative) this package is in the Optional repository.
Post Reply