Openvas 9 Released

Support/Development for OpenVAS
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Openvas 9 Released

Unread post by scott »

Openvas 9 is now available for RHEL/Centos 7, and Fedora 24-25
MikeLim
New Forum User
New Forum User
Posts: 4
Joined: Wed Jun 24, 2015 12:09 am
Location: Singapore

Re: Openvas 9 Released

Unread post by MikeLim »

Many thanks to Atomicorp for this.

Here are my updated install notes for OpenVAS 9 on CentOS 7.3.1611 (minimal install).
Hope someone finds it useful. :shock:

1) Disable SELINUX (edit /etc/selinux/config) and reboot
2) Update your CentOS installation and reboot if necessary
yum -y update
3) Install the follow packages
yum install -y wget bzip2 texlive net-tools alien gnutls-utils
4) Add Atomicorp repo (see https://wiki.atomicorp.com/wiki/index.php/Atomic)
wget -q -O - https://www.atomicorp.com/installers/atomic | sh
5) Install OpenVAS 9
yum install openvas -y
6) edit /etc/redis.conf. Add/uncomment the following
unixsocket /tmp/redis.sock
unixsocketperm 700
7) Restart Redis
systemctl enable redis && systemctl restart redis
8) openvas-setup
Follow instructions and remember your admin password. If rsync throws error, check that your network allows outgoing TCP 873 to internet
9) Open firewall port for tcp/9392
firewall-cmd --permanent --add-port=9392/tcp
firewall-cmd --reload
firewall-cmd --list-port

Go to https://<IP-ADDRESS>:9392 and login.


To verify your OpenVAS setup, run
openvas-check-setup --v9
Last edited by MikeLim on Sun Apr 30, 2017 8:14 pm, edited 1 time in total.
MikeLim
New Forum User
New Forum User
Posts: 4
Joined: Wed Jun 24, 2015 12:09 am
Location: Singapore

PDF generation

Unread post by MikeLim »

If you need to generate PDF from OpenVAS, refer to CentOS 7 instructions at https://wiki.openvas.org/index.php/Gene ... PDF_report
spoonerandrew
New Forum User
New Forum User
Posts: 1
Joined: Mon May 08, 2017 1:10 pm
Location: London

Re: Openvas 9 Released

Unread post by spoonerandrew »

I have just set this up on Fedora 25 using slight tweaks to those instructions (dnf instead of yum). Thanks very much.

Did hit a snag at the point of installing OpenVas. It appears there is a missing dependency of pnscan for Fedora 25 (and I am guessing 24) as it doesn't appear in the repo. I manually installed the rpm from the Fedora 23 repository which so far appears to be working.
sam.whoami
New Forum User
New Forum User
Posts: 1
Joined: Fri Jun 02, 2017 4:46 am
Location: London

Re: PDF generation

Unread post by sam.whoami »

MikeLim wrote:If you need to generate PDF from OpenVAS, refer to CentOS 7 instructions at https://wiki.openvas.org/index.php/Gene ... PDF_report
I found this was needed also

# yum -y install texlive-changepage texlive-titlesec
# mkdir -p /usr/share/texlive/texmf-local/tex/latex/comment
# cd /usr/share/texlive/texmf-local/tex/latex/comment
# wget http://mirrors.ctan.org/macros/latex/co ... omment.sty
# chmod 644 comment.sty
# texhash​
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: Openvas 9 Released

Unread post by scott »

We've added a lot of this input to the openvas package, but havent had the time to test the PDF support completely. That could use some extra vetting if anyone has the opportunity.

Thanks again for all the feedback on this!
Adi85
New Forum User
New Forum User
Posts: 2
Joined: Fri Jul 21, 2017 1:03 am
Location: Germany

Re: Openvas 9 Released

Unread post by Adi85 »

Hello Guys!
I`m new here in this Forum and first i want to say thanks for the great Jobs you are making here.
I´m trying to use Openvas-V9 in my Project on a CentOS 6.9 (Final).
Tryed this Manual two times now, but i am not able to get OpenVAS running, did all the Steps that MikeLim posted above.
Some of the Errors that came up after "openvas-check-Setup" could be fixed with Google(e.g. redis was not installed).
But now i am at the end of my (little) knowledgement.
The Situation ist currently(only the error-part in check-Setup):

ERROR: OpenVAS Manager is NOT running!
FIX: Start OpenVAS Manager (openvasmd).

"service openvas-manager status" says the process is running(it also have a PID).
The openvasmd.log says:
lib auth: INFO:2017-07-25 08h58.54 utc:2547: Authentication configuration not found.
A solution shall be the command: openvasmd --rebuild and/or --update.
I tried both but it changed nothing.

Can anybody help me?
Thanks
Adi85
New Forum User
New Forum User
Posts: 2
Joined: Fri Jul 21, 2017 1:03 am
Location: Germany

Re: Openvas 9 Released

Unread post by Adi85 »

Edit: Sorry for second post. I`ve read over that a mod has to check my post. :?
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: Openvas 9 Released

Unread post by scott »

is redis running and listening on the right socket?
Briner
New Forum User
New Forum User
Posts: 1
Joined: Thu Jul 27, 2017 6:48 am
Location: Seattle

Re: Openvas 9 Released

Unread post by Briner »

scott wrote:is redis running and listening on the right socket?
Hi Scott, how can you tell what the right socket is?
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: Openvas 9 Released

Unread post by scott »

THe default is to look for it at /tmp/redis.sock (this is configurable inside openvas too), anything that might keep that from working could be the culprit. Like selinux, permissions, etc
diego123
New Forum User
New Forum User
Posts: 2
Joined: Sun Aug 13, 2017 8:52 am
Location: Hungary

Re: Openvas 9 Released

Unread post by diego123 »

Hi

I followed the above guide to install Openvas to my CentOS 7 box.

openvas-check-setup --v9
https://pastebin.com/PCvwQEBf

My problem is that, when i create a new single task or host check, the status is "Requested", but when I click on it to see the result it becomes "Internal error". See the below logs.

openvasmd.log
https://pastebin.com/h2JcsqfT

openvassd.log
https://pastebin.com/Qx7BFd5K

[root@testvm neut]# uname -a
Linux testvm 3.10.0-514.26.2.el7.x86_64 #1 SMP Tue Jul 4 15:04:05 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
[root@testvm neut]# cat /etc/redhat-release
CentOS Linux release 7.3.1611 (Core)

I tried googling, but it wasn't successful. Any idea?
parkview
New Forum User
New Forum User
Posts: 1
Joined: Mon Aug 14, 2017 7:59 am
Location: US

Re: Openvas 9 Released

Unread post by parkview »

I have the exact same problem as Diego. My system is a fresh installation on Centos 7 in AWS.

Any advice is appreciated.

j

diego123 wrote:Hi

I followed the above guide to install Openvas to my CentOS 7 box.

openvas-check-setup --v9
https://pastebin.com/PCvwQEBf

My problem is that, when i create a new single task or host check, the status is "Requested", but when I click on it to see the result it becomes "Internal error". See the below logs.

openvasmd.log
https://pastebin.com/h2JcsqfT

openvassd.log
https://pastebin.com/Qx7BFd5K

[root@testvm neut]# uname -a
Linux testvm 3.10.0-514.26.2.el7.x86_64 #1 SMP Tue Jul 4 15:04:05 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
[root@testvm neut]# cat /etc/redhat-release
CentOS Linux release 7.3.1611 (Core)

I tried googling, but it wasn't successful. Any idea?
diego123
New Forum User
New Forum User
Posts: 2
Joined: Sun Aug 13, 2017 8:52 am
Location: Hungary

Re: Openvas 9 Released

Unread post by diego123 »

Okay guys, i give up. OpenVas is unable to run on KVM i guess....

I tried:
CentOS 7
CentOS 6
Ubuntu 14.04
Ubuntu 16.04
Debian 8

OpenVAS never worked on any machines. I followed the guides on the official page... Unfortunately i need to find another software with same knowledge....
edgarsblackanom
New Forum User
New Forum User
Posts: 2
Joined: Thu Jul 20, 2017 12:52 pm
Location: Ecuador

Re: Openvas 9 Released

Unread post by edgarsblackanom »

Greetings,

I have the same problem when running a new scan openvas presents the following message "Internal Error"

Does someone know how to solve this problem?

When run the command openvas-check-setup indicate that the installation is OK

It seems like your OpenVAS-9 installation is OK.
Post Reply