OV9 - CentOS7 - Tasks not starting

Support/Development for OpenVAS
_Scot_
New Forum User
New Forum User
Posts: 3
Joined: Sat Aug 12, 2017 5:09 am
Location: Singapore

OV9 - CentOS7 - Tasks not starting

Unread post by _Scot_ »

Hi,

Any help appreciated!

Very latest CentOS7 updated today, OpenVAS9, checks pass..

'It seems like your OpenVAS-9 installation is OK.'

Tasks do not run fail with 'Internal Error' following is logged in openvasmd.log

event wizard:MESSAGE:2017-08-12 09h01.27 UTC:6315: Wizard quick_first_scan has been run by admin
md manage:WARNING:2017-08-12 09h01.43 UTC:6322: sql_prepare_internal: sqlite3_prepare failed: near "(": syntax error
md manage:WARNING:2017-08-12 09h01.43 UTC:6322: init_iterator: sql_prepare failed
md manage:WARNING:2017-08-12 09h01.43 UTC:6322: manage_cleanup_process_error: Error exit, setting running task to Internal Error
md manage:WARNING:2017-08-12 09h01.43 UTC:6322: sql_prepare_internal: sqlite3_prepare failed: near "(": syntax error
md manage:WARNING:2017-08-12 09h01.43 UTC:6322: init_iterator: sql_prepare failed

Not the first clue where to go from here :)
User avatar
warbenekar1
New Forum User
New Forum User
Posts: 2
Joined: Tue Aug 15, 2017 1:23 pm
Location: Texas

Re: OV9 - CentOS7 - Tasks not starting

Unread post by warbenekar1 »

So I ran into the exact same issue after my last update and after a lot of Google searches came across this page https://wald.intevation.org/tracker/?fu ... roup_id=29

At the bottom it says:
Hi,

the SQL syntax used in OpenVAS 9 (openvas-manager-7.0) needs SQLite 3.8.3 or above where you are running 3.7.17.

I have created an internal ticket to specify this requirement. For now please either update SQLite to a more recent version or stick on OpenVAS 8 which is still compatible with SQLite 3.7.17.
Unfortunately I haven't yet been able to find an RPM version of SQLite 3.8.3 for CentOS 7.

It looks like at one time atmoic had sqlite 3.8.5 for CentOS 6 https://centos.pkgs.org/6/atomic-x86_64 ... 4.rpm.html but no such equivalency appears to exist for CentOS 7.
User avatar
warbenekar1
New Forum User
New Forum User
Posts: 2
Joined: Tue Aug 15, 2017 1:23 pm
Location: Texas

Re: OV9 - CentOS7 - Tasks not starting

Unread post by warbenekar1 »

My openvas box is a virtual machine so I took a snapshot and tried the following:

Code: Select all

yum downgrade openvas-manager openvas-cli openvas-smb openvas-scanner
Then I gave my box a reboot
Now it is working again.

My current installed and working versions are:
openvas.noarch 9.0.0-1244.el7.art
openvas-cli.x86_64 1.4.5-1293.el7.art
openvas-libraries.x86_64 9.0.1-25.el7.art
openvas-manager.x86_64 7.0.1-1230.el7.art
openvas-scanner.x86_64 5.1.1-1985.el7.art

Not sure if this is a practical fix, but it worked for me.
_Scot_
New Forum User
New Forum User
Posts: 3
Joined: Sat Aug 12, 2017 5:09 am
Location: Singapore

Re: OV9 - CentOS7 - Tasks not starting

Unread post by _Scot_ »

Posted a bug report about this, the response :

'the SQL syntax used in OpenVAS 9 (openvas-manager-7.0) needs SQLite
3.8.3 or above where you are running 3.7.17.

I have created an internal ticket to specify this requirement. For now
please either update SQLite to a more recent version or stick on OpenVAS
8 which is still compatible with SQLite 3.7.17.'

I guess ideally the atomic corp repos could do with an update....

Cheers

Scot
berber
New Forum User
New Forum User
Posts: 1
Joined: Wed Aug 16, 2017 8:09 am
Location: Prague

Re: OV9 - CentOS7 - Tasks not starting

Unread post by berber »

Hi,
to workaround this issue, downgrade openvas-manager.x86_64 0:7.0.2-1988.el7.art to openvas-manager.x86_64 0:7.0.1-1230.el7.art (for CentOS 7.x).
B.
reallybigabe
New Forum User
New Forum User
Posts: 2
Joined: Fri Aug 18, 2017 11:35 am
Location: CanadaLand

Re: OV9 - CentOS7 - Tasks not starting

Unread post by reallybigabe »

I grabbed the rpm from http://rpm.pbone.net/index.php3/stat/4/ ... 4.rpm.html

Code: Select all

wget ftp://ftp.pbone.net/mirror/ftp5.gwdg.de/pub/opensuse/repositories/Application:/Geo/CentOS_6/x86_64/sqlite-3.8.8.1-142.1.x86_64.rpm
rpm -U sqlite-3.8.8.1-142.1.x86_64.rpm
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: OV9 - CentOS7 - Tasks not starting

Unread post by scott »

Update should be available now, that brings in a new SCL dependency package: atomic-sqlite-sqlite, this is a parallel install of sqlite that ends up under /opt/atomic/atomic-sqlite/, so it does not overlap with the system installed sqlite package. Its probably overkill to do it like this, but it does guarantee that there wont be any internal conflict if something cant handle a newer sqlite package on the system.
Post Reply