ERROR: Download failed with ERROR (6)

Support/Development for OSSEC
GhostSpirit
New Forum User
New Forum User
Posts: 2
Joined: Sat May 15, 2021 7:05 am

ERROR: Download failed with ERROR (6)

Unread post by GhostSpirit »

root@logonie:/var/ossec/etc# wget -q -O - https://updates.atomicorp.com/installers/oum | bash

OSSEC Updater Modifed (OUM) Installer (v1.0)
Further Documentation is available at:
https://ossec.net

Support: https://ossec.net
Installing the Atomic GPG keys: OK

Hit:1 http://mirror.debian.ikoula.com/debian buster InRelease
Hit:2 http://mirror.debian.ikoula.com/debian buster-updates InRelease
Hit:3 http://mirror.debian.ikoula.com/debian buster-backports InRelease
Hit:4 http://security.debian.org/debian-security buster/updates InRelease
Hit:5 https://updates.atomicorp.com/channels/atomic/debian buster InRelease
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
gpg is already the newest version (2.2.12-1+deb10u1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
W: --force-yes is deprecated, use one of the options starting with --allow instead.
--2021-05-15 10:51:00-- https://www.atomicorp.com/RPM-GPG-KEY.atomicorp.txt
Resolving www.atomicorp.com (www.atomicorp.com)... 74.208.77.16
Connecting to www.atomicorp.com (www.atomicorp.com)|74.208.77.16|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1694 (1.7K) [text/plain]
Saving to: ‘STDOUT’

- 100%[===============================>] 1.65K --.-KB/s in 0s

2021-05-15 10:51:00 (59.7 MB/s) - written to stdout [1694/1694]

OK
Adding [atomic] to /etc/apt/sources.list.d/atomic.list: Already installed
Hit:2 http://security.debian.org/debian-security buster/updates InRelease
Hit:1 http://mirror.debian.ikoula.com/debian buster InRelease
Hit:3 http://mirror.debian.ikoula.com/debian buster-updates InRelease
Hit:4 http://mirror.debian.ikoula.com/debian buster-backports InRelease
Hit:5 https://updates.atomicorp.com/channels/atomic/debian buster InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
Reading package lists... Done
Building dependency tree
Reading state information... Done
oum is already the newest version (0.2-17946buster).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

To complete installation run:
oum configure

and to update your rules:
oum update

root@logonie:/var/ossec/etc# oum configure

OSSEC Updater Modified (OUM) 0.2
Please enter your subscription username [Default: ] XXXX
Please enter your subscription password [Default: ]
Configuration Complete!

To update the system, please run:
oum update

root@logonie:/var/ossec/etc# oum update
===============================================================================
Component Version
===============================================================================
Upgrading:
OSSEC-CRS-Rules 2.0
Atomicorp-Threatfeed 20210513


===============================================================================

Is this ok [y/N]: y
Downloading Rule update: 2.0
ERROR: Download failed with ERROR (6)

ls /var/ossec/oum.conf
ls: cannot access '/var/ossec/oum.conf': No such file or directory

I already change passeword

help me please
User avatar
mikeshinn
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 4136
Joined: Thu Feb 07, 2008 7:49 pm
Location: Chantilly, VA

Re: ERROR: Download failed with ERROR (6)

Unread post by mikeshinn »

Is this on debian?
johnnyboy1981
New Forum User
New Forum User
Posts: 1
Joined: Sat May 22, 2021 8:11 pm

Re: ERROR: Download failed with ERROR (6)

Unread post by johnnyboy1981 »

I'm getting this same error on Centos 8.
User avatar
cponton
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 27
Joined: Fri Oct 09, 2020 9:41 am

Re: ERROR: Download failed with ERROR (6)

Unread post by cponton »

Please go into the oum file at /var/ossec/etc/oum.conf and verify that the credentials have been input to the file and that they are correct. make any changes needed and then save the file.

The run oum update
ciscs
New Forum User
New Forum User
Posts: 2
Joined: Fri May 28, 2021 3:46 pm

Re: ERROR: Download failed with ERROR (6)

Unread post by ciscs »

I'm having the same issue on CentOS 7. The oum.conf does have correct creds and "oum configure" comes back as Verifying account: Passed
Configuration Complete!

Thanks in advance!
User avatar
cponton
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 27
Joined: Fri Oct 09, 2020 9:41 am

Re: ERROR: Download failed with ERROR (6)

Unread post by cponton »

If you would like to try changing the password for the account, you can do so here:
www.atomicorp.com/amember/login

Once changed, update the oum.conf directly and then try and run oum update
ciscs
New Forum User
New Forum User
Posts: 2
Joined: Fri May 28, 2021 3:46 pm

Re: ERROR: Download failed with ERROR (6)

Unread post by ciscs »

Unfortunately same issue even after password change.

"Downloading Rule update: 2.0
ERROR: Download failed with ERROR (6)"

Anything else I can try?
iwa_cslipacoff
New Forum User
New Forum User
Posts: 1
Joined: Tue Jul 27, 2021 1:36 pm

Re: ERROR: Download failed with ERROR (6)

Unread post by iwa_cslipacoff »

I was experiencing the same issue.

The solution I discovered was to change my password to not include special characters. I am not sure which special character was causing the issue but only including alphanumeric characters resolved the issue for me.
Post Reply