store | blogs | forums | twitter | facebook | wiki | downloads | support portal
Atomic Secure Linux
It is currently Tue Oct 22, 2019 9:56 am

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 19 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: QMAIL - Emails are sent from the server IP, not domain IP
Unread postPosted: Wed Apr 02, 2014 12:01 pm 
Offline
Forum User
Forum User

Joined: Fri Dec 14, 2007 11:35 am
Posts: 64
Hi guys,

Is there any easier solution to this:

http://kb.parallels.com/en/111818

https://qmail.jms1.net/patches/combined-details.shtml

I'd like to stick to the Qmail rather than switching to Postfix :)

Running Plesk 11.0.9, psa-qmail-1.03-cos6.build110120606.19.x86_64 and qmail-scanner-2.10-10.el6.art.x86_64


Thanks!


Top
 Profile  
Reply with quote  
 Post subject: Re: QMAIL - Emails are sent from the server IP, not domain I
Unread postPosted: Wed Apr 02, 2014 1:54 pm 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Thu Dec 09, 2004 11:19 am
Posts: 2321
In a word, no. The qmail implementation in Plesk is basic and doesn't allow the IP to match the sending domain's IP. It is always the server's first configured IP. You can change this with some routing things, but it is a permanent change, not a per-domain change.

We are all going to have to go Postfix sooner rather than later, unfortunately. It is still supported in Plesk 12, which surprises me, but if you want all the bells and whistles you have to use Postfix :-(

I do like qmail but Postfix seems to be the way of the future with Plesk.

_________________
--------------------------------
<advert>
If you want to rent a UK-based VPS that comes with friendly advice and support from a fellow ART fan, please get in touch.
</advert>


Top
 Profile  
Reply with quote  
 Post subject: Re: QMAIL - Emails are sent from the server IP, not domain I
Unread postPosted: Wed Apr 02, 2014 2:03 pm 
Offline
Forum User
Forum User

Joined: Fri Dec 14, 2007 11:35 am
Posts: 64
But I hate Postfix! :lol:

How about the Spamassassin and Clamav, will they work with Postfix like they do with Qmail through qmail-scanner?

Oh, I so do not want to change to Postfix :lol:


Top
 Profile  
Reply with quote  
 Post subject: Re: QMAIL - Emails are sent from the server IP, not domain I
Unread postPosted: Wed Apr 02, 2014 4:06 pm 
Offline
Forum Regular
Forum Regular

Joined: Wed Mar 19, 2008 10:22 pm
Posts: 112
I recently converted about 200 domains over to Postfix in Plesk 11.5...so far, I haven't had a single problem with it. Spamassassin and Clamav both work fine. I also installed "clapf" which is essentially like qmail-scanner for Postfix and that also appears to be working fine.

One thing to keep in mind is that I don't think Postfix allows "short names" to log in like Qmail does, so if you have clients using short names you would need to notify all of them about the change.


Top
 Profile  
Reply with quote  
 Post subject: Re: QMAIL - Emails are sent from the server IP, not domain I
Unread postPosted: Wed Apr 02, 2014 5:28 pm 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin

Joined: Wed Dec 31, 1969 8:00 pm
Posts: 8329
Location: earth
Yeah clapf is in the atomic repo, it adds queue type support for spamassassin and clamav much like qmail-scanner does.


Top
 Profile  
Reply with quote  
 Post subject: Re: QMAIL - Emails are sent from the server IP, not domain I
Unread postPosted: Wed Apr 02, 2014 6:09 pm 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Thu Dec 09, 2004 11:19 am
Posts: 2321
yea, we're just missing Spamdyke+Haggy's SCP GUI really.

_________________
--------------------------------
<advert>
If you want to rent a UK-based VPS that comes with friendly advice and support from a fellow ART fan, please get in touch.
</advert>


Top
 Profile  
Reply with quote  
 Post subject: Re: QMAIL - Emails are sent from the server IP, not domain I
Unread postPosted: Fri Apr 04, 2014 5:00 am 
Offline
Forum Regular
Forum Regular

Joined: Tue Jul 15, 2008 2:38 pm
Posts: 805
Location: Sweden
+1 for pamdyke+Haggy's SCP GUI


Top
 Profile  
Reply with quote  
 Post subject: Re: QMAIL - Emails are sent from the server IP, not domain I
Unread postPosted: Fri Apr 04, 2014 7:56 am 
Offline
Forum User
Forum User

Joined: Fri Dec 14, 2007 11:35 am
Posts: 64
Just switched to Postfix, dealing with configs now.

Wanted to install clapf, getting these errors:

[root@alien ~]# yum install clapf
Loaded plugins: fastestmirror, priorities, upgrade-helper
Loading mirror speeds from cached hostfile
* asl-4.0: www6.atomicorp.com
* atomic: mir01.syntis.net
* tortix: www6.atomicorp.com
* tortix-kernel: www6.atomicorp.com
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package clapf.x86_64 0:0.4.7.4-2.el6.art will be installed
--> Processing Dependency: dcc for package: clapf-0.4.7.4-2.el6.art.x86_64
--> Processing Dependency: razor-agents for package: clapf-0.4.7.4-2.el6.art.x86_64
--> Processing Dependency: pyzor for package: clapf-0.4.7.4-2.el6.art.x86_64
--> Processing Dependency: rrdtool for package: clapf-0.4.7.4-2.el6.art.x86_64
--> Running transaction check
---> Package clapf.x86_64 0:0.4.7.4-2.el6.art will be installed
--> Processing Dependency: rrdtool for package: clapf-0.4.7.4-2.el6.art.x86_64
---> Package dcc.x86_64 0:1.3.152-3.el6.art will be installed
--> Processing Dependency: libmilter.so.1.0()(64bit) for package: dcc-1.3.152-3.el6.art.x86_64
---> Package pyzor.noarch 0:0.5.0-4.el6.art will be installed
---> Package razor-agents.x86_64 0:2.85-1.el6.art will be installed
--> Finished Dependency Resolution
Error: Package: dcc-1.3.152-3.el6.art.x86_64 (atomic)
Requires: libmilter.so.1.0()(64bit)
Error: Package: clapf-0.4.7.4-2.el6.art.x86_64 (atomic)
Requires: rrdtool
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
[root@alien ~]#


Top
 Profile  
Reply with quote  
 Post subject: Re: QMAIL - Emails are sent from the server IP, not domain I
Unread postPosted: Fri Apr 04, 2014 8:28 am 
Offline
Forum User
Forum User

Joined: Fri Dec 14, 2007 11:35 am
Posts: 64
Nevermind me, I'm silly, had some repos disabled :D

But I now get this error:

Installed:
clapf.x86_64 0:0.4.7.4-2.el6.art

Dependency Installed:
dcc.x86_64 0:1.3.152-3.el6.art sendmail-milter.x86_64 0:8.14.4-8.el6

Complete!
[root@alien ~]# /etc/init.d/clapf start
Starting Clapf AntiVirus/AntiSpam Daemon: clapf: error while loading shared libraries: libgslcblas.so.0: cannot open shared object file: No such file or directory
[FAILED]


Top
 Profile  
Reply with quote  
 Post subject: Re: QMAIL - Emails are sent from the server IP, not domain I
Unread postPosted: Fri Apr 04, 2014 8:37 am 
Offline
Forum User
Forum User

Joined: Fri Dec 14, 2007 11:35 am
Posts: 64
==========================================================================================================================================================================================================================
Package Arch Version Repository Size
==========================================================================================================================================================================================================================
Installing:
gsl x86_64 1.13-1.el6 base 787 k
gsl-devel x86_64 1.13-1.el6 base 437 k
gsl-static x86_64 1.13-1.el6 base 835 k

Transaction Summary
==========================================================================================================================================================================================================================
Install 3 Package(s)

Total download size: 2.0 M
Installed size: 7.8 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): gsl-1.13-1.el6.x86_64.rpm | 787 kB 00:00
(2/3): gsl-devel-1.13-1.el6.x86_64.rpm | 437 kB 00:00
(3/3): gsl-static-1.13-1.el6.x86_64.rpm | 835 kB 00:00
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total 7.3 MB/s | 2.0 MB 00:00
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : gsl-1.13-1.el6.x86_64 1/3
Installing : gsl-devel-1.13-1.el6.x86_64 2/3
Installing : gsl-static-1.13-1.el6.x86_64 3/3
Verifying : gsl-1.13-1.el6.x86_64 1/3
Verifying : gsl-static-1.13-1.el6.x86_64 2/3
Verifying : gsl-devel-1.13-1.el6.x86_64 3/3

Installed:
gsl.x86_64 0:1.13-1.el6 gsl-devel.x86_64 0:1.13-1.el6 gsl-static.x86_64 0:1.13-1.el6

Complete!
[root@alien ~]# /etc/init.d/clapf start
Starting Clapf AntiVirus/AntiSpam Daemon: [ OK ]
[root@alien ~]#


Top
 Profile  
Reply with quote  
 Post subject: Re: QMAIL - Emails are sent from the server IP, not domain I
Unread postPosted: Fri Apr 04, 2014 12:37 pm 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin

Joined: Wed Dec 31, 1969 8:00 pm
Posts: 8329
Location: earth
So this package definitely needs polishing :P Those dependencies should have been picked up at build time, so something is wrong on my side with those.


Top
 Profile  
Reply with quote  
 Post subject: Re: QMAIL - Emails are sent from the server IP, not domain I
Unread postPosted: Fri Apr 04, 2014 2:56 pm 
Offline
Forum User
Forum User

Joined: Fri Dec 14, 2007 11:35 am
Posts: 64
Good stuff, Scott!

Now trying to set up DKIM and reading these two articles:

http://www.howtoforge.com/set-up-dkim-d ... g-opendkim

http://blog.matoski.com/articles/spf-dk ... sk-debian/

We need opendkim packages in the art repos :D

and some more about tuning the Postfix:

https://www.ispcolohost.com/2013/07/20/ ... -plesk-10/


Top
 Profile  
Reply with quote  
 Post subject: Re: QMAIL - Emails are sent from the server IP, not domain I
Unread postPosted: Fri Apr 04, 2014 6:59 pm 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin

Joined: Wed Dec 31, 1969 8:00 pm
Posts: 8329
Location: earth
Souds good, I added that to the queue


Top
 Profile  
Reply with quote  
 Post subject: Re: QMAIL - Emails are sent from the server IP, not domain I
Unread postPosted: Tue Apr 08, 2014 10:36 am 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin

Joined: Wed Dec 31, 1969 8:00 pm
Posts: 8329
Location: earth
Opendkim is now available in the repo


Top
 Profile  
Reply with quote  
 Post subject: Re: QMAIL - Emails are sent from the server IP, not domain I
Unread postPosted: Wed Apr 09, 2014 4:30 am 
Offline
Forum User
Forum User

Joined: Fri Dec 14, 2007 11:35 am
Posts: 64
Thanks Scott, just tried it:


[root@alien ~]# yum install opendkim
Loaded plugins: fastestmirror, priorities, upgrade-helper
Loading mirror speeds from cached hostfile
* asl-4.0: www6.atomicorp.com
* atomic: mir01.syntis.net
* tortix: www6.atomicorp.com
* tortix-kernel: www6.atomicorp.com
230 packages excluded due to repository priority protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package opendkim.x86_64 0:2.9.0-2.el6.art will be installed
--> Processing Dependency: libopendkim = 2.9.0-2.el6.art for package: opendkim-2.9.0-2.el6.art.x86_64
--> Processing Dependency: libbsd.so.0(LIBBSD_0.0)(64bit) for package: opendkim-2.9.0-2.el6.art.x86_64
--> Processing Dependency: libbsd.so.0()(64bit) for package: opendkim-2.9.0-2.el6.art.x86_64
--> Processing Dependency: libunbound.so.2()(64bit) for package: opendkim-2.9.0-2.el6.art.x86_64
--> Processing Dependency: libopendkim.so.9()(64bit) for package: opendkim-2.9.0-2.el6.art.x86_64
--> Finished Dependency Resolution
Error: Package: opendkim-2.9.0-2.el6.art.x86_64 (atomic)
Requires: libopendkim.so.9()(64bit)
Error: Package: opendkim-2.9.0-2.el6.art.x86_64 (atomic)
Requires: libopendkim = 2.9.0-2.el6.art
Error: Package: opendkim-2.9.0-2.el6.art.x86_64 (atomic)
Requires: libunbound.so.2()(64bit)
Error: Package: opendkim-2.9.0-2.el6.art.x86_64 (atomic)
Requires: libbsd.so.0()(64bit)
Error: Package: opendkim-2.9.0-2.el6.art.x86_64 (atomic)
Requires: libbsd.so.0(LIBBSD_0.0)(64bit)
You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
kernel-debug-2.6.32-431.11.2.el6.x86_64 has missing requires of dracut-kernel >= ('0', '002', '18.git413bcf78')


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 19 posts ]  Go to page 1, 2  Next

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group