MySQL 5.5.47

Requests for RPMS, or new coding projects related to server administration, Plesk, security, or anything else you can think of.
Imaging
Forum Regular
Forum Regular
Posts: 333
Joined: Sat Sep 25, 2010 2:46 pm

MySQL 5.5.47

Unread post by Imaging »

Could the atomic 5.5.x MySQL packages (for CentOS 5.x, 6.x, etc.) be updated to 5.5.47?

Thanks.
Imaging
Forum Regular
Forum Regular
Posts: 333
Joined: Sat Sep 25, 2010 2:46 pm

Re: MySQL 5.5.47

Unread post by Imaging »

Thanks for the new packages but unfortunately we are seeing:

error: rpmts_HdrFromFdno: Header V4 RSA/SHA1 signature BAD, key ID 4520afa9

when we attempt to upgrade to the new el5 mysql packages.

Thanks.
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: MySQL 5.5.47

Unread post by scott »

I believe you might not have the newer GPG key, which is in the atomic-release package
Imaging
Forum Regular
Forum Regular
Posts: 333
Joined: Sat Sep 25, 2010 2:46 pm

Re: MySQL 5.5.47

Unread post by Imaging »

Scott:

Thanks.

From our post in the other thread:

__

As best we can see we have the latest version of the atomic-release package so perhaps not the issue. It appears to be related to the V4 sig versus the V3 on other packages.

To double-check, we did a clean all and we reinstalled atomic-release from the repos which pulled down:

atomic-release-1.0-19.el5.art.noarch.rpm

After that install we tried updating and the packages are still giving the error.

__
jestep
New Forum User
New Forum User
Posts: 4
Joined: Thu Dec 24, 2015 2:36 am
Location: California

Re: MySQL 5.5.47

Unread post by jestep »

Imaging wrote:Thanks for the new packages but unfortunately we are seeing:

error: rpmts_HdrFromFdno: Header V4 RSA/SHA1 signature BAD, key ID 4520afa9

when we attempt to upgrade to the new el5 mysql packages.

Thanks.

I also have this issues. Any luck yet??
SparkyMarky
New Forum User
New Forum User
Posts: 1
Joined: Fri Dec 25, 2015 5:28 am
Location: UK

Re: MySQL 5.5.47

Unread post by SparkyMarky »

I'm seeing the same issue, on CentOS 5.x

Code: Select all

error: mysql-libs-5.5.47-32.el5.art: Header V4 RSA/SHA1 signature: BAD, key ID 4520afa9
error: mysql-5.5.47-32.el5.art: Header V4 RSA/SHA1 signature: BAD, key ID 4520afa9
error: mysql-server-5.5.47-32.el5.art: Header V4 RSA/SHA1 signature: BAD, key ID 4520afa9

Code: Select all

 rpm --checksig -v mysql-5.5.47-32.el5.art.x86_64.rpm
mysql-5.5.47-32.el5.art.x86_64.rpm:
    Header V4 RSA/SHA1 signature: BAD, key ID 4520afa9
    Header SHA1 digest: OK (e5f8e32ce85747bd345222ada276da485ce929aa)
    V4 RSA/SHA1 signature: BAD, key ID 4520afa9
    MD5 digest: OK (0ec94ee9097db24bba35c8e1792d1004)

litux
New Forum User
New Forum User
Posts: 2
Joined: Sat Dec 26, 2015 6:30 am
Location: Bilthoven

Re: MySQL 5.5.47

Unread post by litux »

Here the same problem while updating with yum update.
mysql-libs-5.5.47-32.el5.art.i386.rpm | 1.1 MB 00:00
error: rpmts_HdrFromFdno: Header V4 RSA/SHA1 signature: BAD, key ID 4520afa9
Centos 5.11

Even after cleaning with yum clean all the problem persists
jestep
New Forum User
New Forum User
Posts: 4
Joined: Thu Dec 24, 2015 2:36 am
Location: California

Re: MySQL 5.5.47

Unread post by jestep »

Was there any fix to this? I am seeing this same issue and have done a clean all and still get this error
welbers
New Forum User
New Forum User
Posts: 1
Joined: Tue Dec 29, 2015 9:49 am
Location: Germany

Re: MySQL 5.5.47

Unread post by welbers »

Yes, it seems to be a general problem with atomic V4 Signature / Key. It's not only related to mysql.

We have this problem on different servers with CentOS5 i386 and latest atomicorp updates.

Example: mysql* and clamav*

Output:
yum update --disablerepo=\* --enablerepo=atomic clamav mysql
Loaded plugins: fastestmirror, priorities, protect-packages, protectbase
Loading mirror speeds from cached hostfile
* atomic: mirror1.34sp.com
atomic | 2.2 kB 00:00
0 packages excluded due to repository protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: libclamav.so.6 for package: clamav-devel
--> Processing Dependency: libclamav.so.6 for package: clamd
--> Processing Dependency: libclamav.so.6(CLAMAV_PRIVATE) for package: clamd
--> Processing Dependency: libclamav.so.6(CLAMAV_PUBLIC) for package: clamd
--> Processing Dependency: libclamunrar.so.6 for package: clamav-devel
--> Processing Dependency: libclamunrar_iface.so.6 for package: clamav-devel
--> Processing Dependency: clamav = 0.98.7-24.el5.art for package: clamav-devel
--> Processing Dependency: clamav = 0.98.7-24.el5.art for package: clamd
---> Package clamav.i386 0:0.99-25.el5.art set to be updated
--> Processing Dependency: real-mysql = 5.5.46-31.el5.art for package: mysql-server
--> Processing Dependency: real-mysql = 5.5.46-31.el5.art for package: mysql-devel
---> Package mysql.i386 0:5.5.47-32.el5.art set to be updated
--> Processing Dependency: real-mysql-libs = 5.5.47-32.el5.art for package: mysql
--> Running transaction check
---> Package clamav-devel.i386 0:0.99-25.el5.art set to be updated
--> Processing Dependency: clamd = 0.98.7-24.el5.art for package: clamav-milter
---> Package clamd.i386 0:0.99-25.el5.art set to be updated
---> Package mysql-devel.i386 0:5.5.47-32.el5.art set to be updated
---> Package mysql-libs.i386 0:5.5.47-32.el5.art set to be updated
---> Package mysql-server.i386 0:5.5.47-32.el5.art set to be updated
--> Running transaction check
---> Package clamav-milter.i386 0:0.99-25.el5.art set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================================================================================================
Package Arch Version Repository Size
================================================================================================================================================================
Updating:
clamav i386 0.99-25.el5.art atomic 15 M
mysql i386 5.5.47-32.el5.art atomic 7.6 M
Updating for dependencies:
clamav-devel i386 0.99-25.el5.art atomic 22 k
clamav-milter i386 0.99-25.el5.art atomic 111 k
clamd i386 0.99-25.el5.art atomic 273 k
mysql-devel i386 5.5.47-32.el5.art atomic 167 k
mysql-libs i386 5.5.47-32.el5.art atomic 1.1 M
mysql-server i386 5.5.47-32.el5.art atomic 13 M

Transaction Summary
================================================================================================================================================================
Install 0 Package(s)
Upgrade 8 Package(s)

Total download size: 38 M
Is this ok [y/N]: y
Downloading Packages:
(1/8): clamav-devel-0.99-25.el5.art.i386.rpm | 22 kB 00:00
(2/8): clamav-milter-0.99-25.el5.art.i386.rpm | 111 kB 00:00
(3/8): mysql-devel-5.5.47-32.el5.art.i386.rpm | 167 kB 00:00
(4/8): clamd-0.99-25.el5.art.i386.rpm | 273 kB 00:00
(5/8): mysql-libs-5.5.47-32.el5.art.i386.rpm | 1.1 MB 00:00
(6/8): mysql-5.5.47-32.el5.art.i386.rpm | 7.6 MB 00:00
(7/8): mysql-server-5.5.47-32.el5.art.i386.rpm | 13 MB 00:00
(8/8): clamav-0.99-25.el5.art.i386.rpm | 15 MB 00:04
----------------------------------------------------------------------------------------------------------------------------------------------------------------
Total 5.0 MB/s | 38 MB 00:07
error: rpmts_HdrFromFdno: Header V4 RSA/SHA1 signature: BAD, key ID 4520afa9


Problem opening package clamav-0.99-25.el5.art.i386.rpm
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: MySQL 5.5.47

Unread post by scott »

Can you check to see if you have this key installed:

rpm -qa |grep 4520afa9

We're looking for:
gpg-pubkey-4520afa9-50ab914c.(none)
Imaging
Forum Regular
Forum Regular
Posts: 333
Joined: Sat Sep 25, 2010 2:46 pm

Re: MySQL 5.5.47

Unread post by Imaging »

Returns:

rpm -qa | grep 4520afa9
gpg-pubkey-4520afa9-50ab914c.(none)
jestep
New Forum User
New Forum User
Posts: 4
Joined: Thu Dec 24, 2015 2:36 am
Location: California

Re: MySQL 5.5.47

Unread post by jestep »

scott wrote:Can you check to see if you have this key installed:

rpm -qa |grep 4520afa9

We're looking for:
gpg-pubkey-4520afa9-50ab914c.(none)

I get :

rpm -qa |grep 4520afa9
gpg-pubkey-4520afa9-50ab914c

And still get the error

error: rpmts_HdrFromFdno: Header V4 RSA/SHA1 signature: BAD, key ID 4520afa9


Problem opening package mysql-server-5.5.47-32.el5.art.x86_64.rpm
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: MySQL 5.5.47

Unread post by scott »

Ok we have an interm workaround in place. Some of the build cluster nodes, no matter how they are configured, will not produce a V3 signed package. We have a single legacy FC21 build node that we can continue to make those packages on.

You should clear your cache, and try to update again. All of our mirrors are up to date,but the updated mirrors may be behind so you might have to repeat this a few times to get a more up to date one
litux
New Forum User
New Forum User
Posts: 2
Joined: Sat Dec 26, 2015 6:30 am
Location: Bilthoven

Re: MySQL 5.5.47

Unread post by litux »

Problems fixed! Tnx
Post Reply