Atomic Secured Linux™ 4.0.3 (maintenance update)

Atomicorp announcements, new release notifications and other company and product news.
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8330
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Atomic Secured Linux™ 4.0.3 (maintenance update)

Unread post by scott »

Release Notes

This is a maintenance update to ASL 4.0. New features in this update include the ability to apply the PHP security policy settings to all domain level php.ini files using the PSA_PHP_DOMAIN_POLICY setting (Default: Disabled).



Changelog



Add debian jessie detection to AUM
Update cpanel build events, add rpmbuild dependency into templates
Update AUM, RULES_PATH support to the fixed vhost & global file creation (this is needed for planned apache 2.4 support)
Feature Request #1519, ASL Web, Add snat,dnat,masquerade,redirect handling to ASL Web firewall interface
Feature Request #1568, generate vhost php.ini files from master file (PSA_PHP_DOMAIN_POLICY)
Bugfix #1571, waf_check, waf_check error on asl -s -f when MODSEC_ENABLED=no
Bugfix #1573, AUM, fix validate_asl Nothing from request condition
Bugfix #XXX, ASL Web, Fixes event detail viewing on blocked ips



To Upgrade:

1) Read the release notes:
https://www.atomicorp.com/wiki/index.ph ... _4.0_Notes

2) aum -uf

3) asl -s -f
Locked