store | blogs | forums | twitter | facebook | wiki | downloads | support portal
Atomic Secure Linux
It is currently Thu Mar 21, 2019 10:19 pm

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 48 posts ]  Go to page Previous  1, 2, 3, 4  Next
Author Message
 Post subject: Re: disable_functions in php.ini for webmail
Unread postPosted: Wed Oct 07, 2009 9:59 am 
Offline
Forum Regular
Forum Regular

Joined: Tue Jul 15, 2008 2:38 pm
Posts: 805
Location: Sweden
breun wrote:

Anyway, what we're doing might be even more interesting. We're not using Suhosin, but have popen (and exec and all their friends) disabled globally and configure Horde to use SMTP instead of sendmail. Problem solved!


Interesting... How did you do that? I guess it has something to do with horde configuration in /etc/psa-horde/horde/conf.xml


Top
 Profile  
Reply with quote  
 Post subject: Re: disable_functions in php.ini for webmail
Unread postPosted: Wed Oct 07, 2009 10:07 am 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Sat Aug 20, 2005 9:30 am
Posts: 2813
Location: The Netherlands
No, not conf.xml, but conf.php. So, /etc/psa-horde/horde/conf.php on Plesk 8 or /etc/psa/webmail/horde/horde/conf.php on Plesk 9.

Change $conf['mailer']['type'] from 'sendmail' to 'smtp' and add this line:

Code:
$conf['mailer']['params']['host'] = 'localhost';


Updates to psa-horde might overwrite this change.

_________________
Lemonbit Internet Dedicated Server Management


Top
 Profile  
Reply with quote  
 Post subject: Re: disable_functions in php.ini for webmail
Unread postPosted: Wed Oct 07, 2009 10:20 am 
Offline
Forum Regular
Forum Regular

Joined: Tue Jul 15, 2008 2:38 pm
Posts: 805
Location: Sweden
Works like a charm! Thanks a lot!


Top
 Profile  
Reply with quote  
 Post subject: Re: disable_functions in php.ini for webmail
Unread postPosted: Thu Dec 17, 2009 5:02 pm 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Sat Aug 20, 2005 9:30 am
Posts: 2813
Location: The Netherlands
With the latest update of psa-horde (psa-horde-3.1.7 build92091210.12) for Plesk 9 the path to conf.php has changed to /etc/psa-webmail/horde/horde/conf.php

Apply the change again there.

_________________
Lemonbit Internet Dedicated Server Management


Top
 Profile  
Reply with quote  
 Post subject: Re: disable_functions in php.ini for webmail
Unread postPosted: Fri Dec 18, 2009 8:36 am 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Thu Dec 09, 2004 11:19 am
Posts: 2321
Thanks for the update Breun.

Please can this be added to the Wiki? Maybe under "Plesk hints and tips - Horde" (as well as others).

_________________
--------------------------------
<advert>
If you want to rent a UK-based VPS that comes with friendly advice and support from a fellow ART fan, please get in touch.
</advert>


Top
 Profile  
Reply with quote  
 Post subject: Re: disable_functions in php.ini for webmail
Unread postPosted: Fri Dec 18, 2009 9:39 am 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Sat Aug 20, 2005 9:30 am
Posts: 2813
Location: The Netherlands
Go ahead, it's a wiki. :)

_________________
Lemonbit Internet Dedicated Server Management


Top
 Profile  
Reply with quote  
 Post subject: Re: disable_functions in php.ini for webmail
Unread postPosted: Fri Dec 18, 2009 11:22 am 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Thu Dec 09, 2004 11:19 am
Posts: 2321
I've never been able to register on it. I forget what the problem was. I'll try again....

EDIT: Hmm... I seem to be registered on the wiki and have been for some time. Interesting.

_________________
--------------------------------
<advert>
If you want to rent a UK-based VPS that comes with friendly advice and support from a fellow ART fan, please get in touch.
</advert>


Top
 Profile  
Reply with quote  
 Post subject: Re: disable_functions in php.ini for webmail
Unread postPosted: Fri Dec 18, 2009 6:20 pm 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
User avatar

Joined: Thu Feb 07, 2008 7:49 pm
Posts: 4069
Location: Chantilly, VA
Quote:
EDIT: Hmm... I seem to be registered on the wiki and have been for some time. Interesting.


Its your doppelgänger!

_________________
Michael Shinn
Atomicorp - Security For Everyone


Top
 Profile  
Reply with quote  
 Post subject: Re: disable_functions in php.ini for webmail
Unread postPosted: Mon Jan 25, 2010 6:23 pm 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Sat Aug 20, 2005 9:30 am
Posts: 2813
Location: The Netherlands
On some servers we use max_load and per_source limits in /etc/xinitd.d/smtp_psa and /etc/xinitd.d/smtps_psa so evildoers cannot overload the server with mail traffic. However, when the server load reaches max_load, this also means webmail users cannot send e-mail. I wanted to configure webmail to use submission (SMTP on port 587), because there are no load limits on that, but somehow setting $conf['mailer']['params']['port'] = 587; does not seem to work (webmail still uses SMTP via port 25). According to various posts I found this setting should work for Horde. Anyone here has any ideas?

_________________
Lemonbit Internet Dedicated Server Management


Top
 Profile  
Reply with quote  
 Post subject: Re: disable_functions in php.ini for webmail
Unread postPosted: Tue Jan 26, 2010 8:32 am 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Thu Dec 09, 2004 11:19 am
Posts: 2321
Could it be because submission requires auth, and even localhost has to auth?

Faris.

_________________
--------------------------------
<advert>
If you want to rent a UK-based VPS that comes with friendly advice and support from a fellow ART fan, please get in touch.
</advert>


Top
 Profile  
Reply with quote  
 Post subject: Re: disable_functions in php.ini for webmail
Unread postPosted: Tue Jan 26, 2010 8:59 am 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Sat Aug 20, 2005 9:30 am
Posts: 2813
Location: The Netherlands
I think you're right, faris. Though I didn't expect Horde to fall back to trying port 25 after trying port 587 without auth and then give an error message about port 25 when it is not available (disabled it for testing), but that might be what's happening here. I'll dig in some more when I have time.

_________________
Lemonbit Internet Dedicated Server Management


Top
 Profile  
Reply with quote  
 Post subject: Re: disable_functions in php.ini for webmail
Unread postPosted: Mon May 17, 2010 6:29 am 
Offline
Forum Regular
Forum Regular

Joined: Sat Mar 28, 2009 6:58 pm
Posts: 879
Location: Germany
thanks breun for the solution to get rid of the php limitations.
I have configured to use smtp in horde. But I have a problem with mails people send from horde to an account that is located on the server.
due to graylisting via spamdyke people are not able to send mails wiht this error:
Failed to add recipient: mail@domain.tld [SMTP: Invalid response code received from server (code: 421, response: Your address has been graylisted. Try again later.)]"
127.0.0. is whitlisted.
anyone have a clue how to get rid of this?
thanks for any help


Top
 Profile  
Reply with quote  
 Post subject: Re: disable_functions in php.ini for webmail
Unread postPosted: Mon May 17, 2010 6:35 am 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Sat Aug 20, 2005 9:30 am
Posts: 2813
Location: The Netherlands
Since there is no local queue involved when using SMTP sending the message has to succeed at the first try or, well... it will fail. :)

So yeah, graylisting is not compatible with using SMTP for webmail.

_________________
Lemonbit Internet Dedicated Server Management


Top
 Profile  
Reply with quote  
 Post subject: Re: disable_functions in php.ini for webmail
Unread postPosted: Mon May 17, 2010 6:40 am 
Offline
Forum Regular
Forum Regular

Joined: Sat Mar 28, 2009 6:58 pm
Posts: 879
Location: Germany
thanks breun, that makes sence. maybe the submission port would work.
have you tried changing port number in this file to set port 587?
/etc/psa-webmail/horde/imp/servers.php

baesd on:
http://kb.parallels.com/article_22_837_en.html


Top
 Profile  
Reply with quote  
 Post subject: Re: disable_functions in php.ini for webmail
Unread postPosted: Mon May 17, 2010 6:44 am 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Sat Aug 20, 2005 9:30 am
Posts: 2813
Location: The Netherlands
Last time I checked Horde configs contain code that hardcode port 25 for SMTP. If you manage to convince Horde to use port 587 you will also need to configure authentication somehow.

_________________
Lemonbit Internet Dedicated Server Management


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 48 posts ]  Go to page Previous  1, 2, 3, 4  Next

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group