Project-gamera on CentOS 6

Forum for getting help with Project Gamera, Spamassassin, Clamav, qmail-scanner and other anti-spam tools.
CrK01
Forum User
Forum User
Posts: 94
Joined: Wed Jun 06, 2007 10:49 am

Project-gamera on CentOS 6

Unread post by CrK01 »

Hi,

I just wanted to install a new server with project-gamera to filter mail outside out servers.

I remember I used this without problem many years ago.

Well , I follow the instructions described in: http://www.atomicrocketturtle.com/Jooml ... &Itemid=32

This is a fresh CentOS 6 install ( x64 ) , and after the installation I make a qmail-scanner-reconfigure to make spamassassin and clamd work together with qmail-scanner but it throws this error:

[root@gamera1 ~]# qmail-scanner-reconfigure
Reconfiguring spamassassin settings: Done
Reconfiguring clamav settings: Done
Configuring qmail-scanner: setuidgid: fatal: unable to run /var/qmail/bin/qmail-scanner-queue.pl: file does not exist
setuidgid: fatal: unable to run /var/qmail/bin/qmail-scanner-queue.pl: file does not exist
OK

I'm not new to qmail-scanner / SA / Clamav.

I only use the base repo and ART's repo.

Also, there aren't anymore a qgreylist package ?

I tried this on a fresh CentOS minimal install X64 6.0 and I tried upgrading it to CentOS 6.4 , same result. I tried with SA started / stopped as Clamd started / stopped

Any clue ?

regards,
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8337
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: Project-gamera on CentOS 6

Unread post by scott »

Not sure about that, but qgreylist should be up in a sec.
CrK01
Forum User
Forum User
Posts: 94
Joined: Wed Jun 06, 2007 10:49 am

Re: Project-gamera on CentOS 6

Unread post by CrK01 »

Ok I've located qgreylist but only in "testing" repo.

Is it normal that qgreylist doesn't exists in Centos 6 ( x64 ) base repo ?

Anyway, with testing repo I can't make a "vanilla" qmail-scanner work .

If I copy /var/qmail/bin/qmail-scanner-queue.pl from other working ( plesk ) machine it works but complains about clamscan memory/corrupt error
spaceout
Forum Regular
Forum Regular
Posts: 112
Joined: Wed Mar 19, 2008 10:22 pm

Re: Project-gamera on CentOS 6

Unread post by spaceout »

I've been having trouble installing Gamera on a fresh 6.5 install. Nothing seems to get configured with clamav. It's just the "Example" config file and it won't start.
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8337
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: Project-gamera on CentOS 6

Unread post by scott »

Ah, so its just missing the right clamd.conf? That logic might have all ended up in ASL these days
spaceout
Forum Regular
Forum Regular
Posts: 112
Joined: Wed Mar 19, 2008 10:22 pm

Re: Project-gamera on CentOS 6

Unread post by spaceout »

That appears to be the case. Everything else looks fine so far.
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8337
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: Project-gamera on CentOS 6

Unread post by scott »

As I recall, the default config isnt too bad. I think you just have to comment Example out.
Post Reply