is support for apache 2.4 coming anytime soon?

Customer support forums for the modsecurity rules feed. There is no such thing as a bad question here as long as it pertains to using the real time modsecurity rules feed. Newbies feel free to get help getting started or asking questions that may be obvious.
srpurdy
Forum Regular
Forum Regular
Posts: 110
Joined: Sat Jan 21, 2012 6:37 pm
Location: Canada

is support for apache 2.4 coming anytime soon?

Unread post by srpurdy »

I'm just wondering. I'd like to phase out 2.2 but lack of support for 2.4 is only thing holding me back from switching to 2.4. At least according to the wiki it's still not supported. Any ideas on when it will be?

Thanks
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8337
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: is support for apache 2.4 coming anytime soon?

Unread post by scott »

Its supported in EL7 and cpanel systems using 2.4 now. Although we do recommend using Apache 2.2 over 2.4 for performance reasons.
srpurdy
Forum Regular
Forum Regular
Posts: 110
Joined: Sat Jan 21, 2012 6:37 pm
Location: Canada

Re: is support for apache 2.4 coming anytime soon?

Unread post by srpurdy »

I'm on Centos 6.5 and Cloudlinux, using cpanel still not supported? Will it be? or is it only EL7?

Mainly I'm trying to get more performance out of https. I find it so much slower than http protocol. I'm not sure if 2.4 is faster though, but it was my reasoning for wanting to switch. mod_spdy seems to be early on, so it's not an option as of now. :)

Typically average respond time for http page is around 100-130ms, where it is 750ms in https. At times it can go over 1 second.

Being a performance nut. I doubt I would switch unless performance was better. :P
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8337
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

Re: is support for apache 2.4 coming anytime soon?

Unread post by scott »

I'm on Centos 6.5 and Cloudlinux, using cpanel still not supported? Will it be? or is it only EL7?
Cpanel's Apache 2.4 is supported on EL6 (RHEL, Centos, cloudlinux, yadda yadda). EL7 comes with Apache 2.4 natively, so if you're on that everything else (Plesk, webmin, etc) inherits support for it.

Mainly I'm trying to get more performance out of https. I find it so much slower than http protocol. I'm not sure if 2.4 is faster though, but it was my reasoning for wanting to switch. mod_spdy seems to be early on, so it's not an option as of now. :)
Yeah https is just slow by the nature of wrapping everything in encryption. Faster CPUs and things like mod_spdy would help here. Thing is though, Im pretty sure mod_spdy isnt compatible with apache 2.4, which doesn't surprise me since we had to jump through a bunch of API hoops to get other modules working in it.
Post Reply