[atomic] nginx 1.2.8 w/ mod_security support

Atomic repository announcements, new release notifications and other news regarding the atomic yum repository.
scott
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
Posts: 8338
Joined: Wed Dec 31, 1969 8:00 pm
Location: earth
Contact:

[atomic] nginx 1.2.8 w/ mod_security support

Unread post by scott »

This is the initial release for RHEL/Centos 6 and up to FC17 RPMs of nginx with native mod_security support.

EL5 and Fedora 18 builds are forthcoming!

1) Set up the atomic repo:

wget -q -O - http://www.atomicorp.com/installers/atomic |sh

Or via SSL:

wget -q -O - https://www.atomicorp.com/installers/atomic |sh

2) Install nginx:

yum install nginx

At this point the modsecurity code for nginx is documented as beta quality by the modsecurity project. Therefore the current mod_security implementation for nginx should be considered potentially buggy and possibly incomplete. If you can not use beta code, then you should use Apache and the apache modsecurity module which is considered stable by the modsecurity project.
Post Reply